AutoLog

5 - Combatlog will not be reenabled on relog/reloadui

What steps will reproduce the problem?
1. Enter instance that is enabled for logging in AutoLog
2. ReloadUI or Relog

What is the expected output? What do you see instead?
Combatlog Enabled instead of Combatlog Disabled ;)

What version of the product are you using?
latest

Please provide any additional information below.

This Malfunction can easily be fixed by changing the following lines in Core.lua

--[[ Enable function : Register event ]]--
function AutoLog:OnEnable()

    self:Print("Version " .. GetAddOnMetadata("AutoLog","Version") .. L[" loaded."])
    self:RegisterEvent("ZONE_CHANGED_NEW_AREA")
    self:RegisterEvent("PLAYER_ENTERING_WORLD")
    AutoLog:CheckLog()

end

--[[ Disable function ... should not be called, but must exist ]]--
function AutoLog:OnDisable()

    self:Print(L["AutoLog Disabled"])
    self:UnregisterEvent("ZONE_CHANGED_NEW_AREA")

    end

--[[ Event handler ]]--
function AutoLog:ZONE_CHANGED_NEW_AREA()
    
    AutoLog:CheckLog()

end

function AutoLog:PLAYER_ENTERING_WORLD()
    
    AutoLog:CheckLog()

end

User When Change
Deepac Jul 30, 2011 at 06:16 UTC
Aratar Jul 29, 2011 at 22:43 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of Deepac Deepac Jul 30, 2011 at 06:15 UTC - 0 likes

    Thanks for that. Your changes have been added.

  • 1 comment

Facts

Last updated
Jul 30, 2011
Reported
Jul 29, 2011
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees