Clique

89 - Raid Frames not being recognised?

What steps will reproduce the problem?
1. Hover over target I intend to heal
2. Press appropriate button to cast relevant spell (e.g. number 2 bound to Rejuvenation)
3. The spell is often cast on the person below my desired target on the raid frames, or not cast at all.

What is the expected output? What do you see instead?
I would expect to see desired spell (e.g. Rejuv) cast on the target I am hovering over.
I instead see the spell cast on the raid member below that target on the frames, or see no cast at all.

What version of the product are you using?
v50100-1.0.0

Do you have an error log of what happened?
-

Please provide any additional information below.
I know I am not the only person having this issue.  Fellow Resto Druid in my raid force is having this problem, as well as issues with casting the wrong spells (she has spells bound for when hovering over a target, and others for when not.  The issue being that when not hovering over a target, the spells for when she IS hovering over a target are being cast... if that makes sense?).
Myself and the other Resto Druid are both currently using the default raid frames.  I am waiting to hear back from our Resto Shaman to see if he has had any similar issues (as far as I'm aware he uses Clique with Grid).
Will update with forther info if/when I get any.

User When Change
Mellifera90 Jan 14, 2013 at 12:17 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 7 comments
  • Avatar of Cladhaire Cladhaire Mar 01, 2013 at 15:29 UTC - 0 likes

    @John454ss: Go

    Yeah, I understand all of that, but that's not really anything I can help with.. I'm not doing any of that.

  • Avatar of Soulman69 Soulman69 Mar 01, 2013 at 15:27 UTC - 0 likes

    @Cladhaire: Go "... just moving the mouse off and back on the frame should be enough to update which bindings are active ..."

    Tried this, but no joy there. I tested a bunch of scenarios while in an AV BG (where players leave/join fairly often and found that the problem is consistent after a leave/join as follows:

    1) It's usually an off-by-one error, where the frame I am trying to heal actually winds up belonging to a player directly above (never seen it go the other way). Example: I try to cast Flash of Light on the frame in row 2, column 3 but see my heal going to row 1, column 3.

    2) Less common, but I did also see something like row 4, column 4 going to row 2, column 1. I vaguely remember this occurring after a handful of leaves/joins. Stumbled upon it only once.

    3) /reload always fixes the problem but unfortunately it's a process whose duration is long enough to count as an eternity in a BG. =^)

    @Cladhaire: Go "Can you please give me an example set of bindings you would expect to reproduce this issue?"

    I tested Flash of Light, Divine Light, Holy Shock, Holy Light, and Holy Prism; all had the same problem.

  • Avatar of John454ss John454ss Mar 01, 2013 at 12:29 UTC - 0 likes

    I did some research since this occurs with my default raid frames as well:

    "Addons can also create drop down menus by making use of the same UIDropDownMenu_Initialize and UIDropDownMenu_AddButton functions that Blizzard uses. When an addon uses those functions, certain things that are also used by Blizzard become tainted (not secure). Then when Blizzard later creates a secure frame (such as a compact raid frame), that frame may also become tainted. When the game tries to do certain things to a secure frame that has become tainted (such as showing, hiding, or moving it during combat) you will end up with errors."

    BlizzInterface_enUS\FrameXML -- line 2:
    UIDROPDOWNMENU_MAXBUTTONS = 8;

    Anytime an addon tries to go beyond 8 the compact raid frame taint starts.

    Last edited Mar 01, 2013 by John454ss
  • Avatar of Cladhaire Cladhaire Feb 19, 2013 at 05:30 UTC - 0 likes

    @Soulman69: Go

    If that is the case, there's not much I can do to resolve the issue, other than report it to Blizzard. Clique makes use of the 'mouseover' unit, which is like 'target', and 'focus', and 'player', except refers to the "unit that the mouse is currently over, or the unit set on the unit frame the mouse is currently over".

    There's no special or conditional logic that I'm using, because WoW doesn't allow any in these cases.

    But there's several potential issues being described here. One is when a frame appears under the mouse (or disappears). In this case, just moving the mouse off and back on the frame should be enough to update which bindings are active (which seems to be the issue with your fellow resto druid).

    If I can this weekend I'll spend some time trying to reproduce this, although finding a situation where I am in combat and can have someone join/leave my raid will be difficult if not impossible. Can you please give me an example set of bindings you would expect to reproduce this issue?

  • Avatar of Soulman69 Soulman69 Feb 18, 2013 at 22:25 UTC - 0 likes

    @Cladhaire: Go

    I *think* I've found a smoking gun for this bug. I have had this problem occur 3 times now with the following conditions:

    1) In a raid (I think each time it was more than 20 members)

    2) The frames were reordered, either due to someone leaving, joining, or the raid leader moving people around. I can't say which of these, either singly or in combination occurred.

    This is circumstantial, so ymmv. I was able to correct the problem each time with a /reload.

    gl!

    Additional info: I'm using blizzard raid frames along with RaidFrameIndicators.

    Last edited Feb 19, 2013 by Soulman69
  • Avatar of Cladhaire Cladhaire Jan 15, 2013 at 06:35 UTC - 0 likes

    Any more specific information you can provide would be useful. Some things to know:

    You can't bind two things to the same key/click. If you do, you will get one or the other depending on how the hash table was traversed. Bindings must be mutually exclusive.

    Also, 'hovecast' spells work on unit frames as well in exactly the same way they do on units in the 3D world. When you mouse over a unit frame, the game views it exactly the same as when you mouse over a unit in the world.

    Any specific information you can provide would be useful. i know of no other cases of people having this issue.

  • Avatar of Cladhaire Cladhaire Jan 15, 2013 at 06:32 UTC - 0 likes

    What raid frames? What binding?

  • 7 comments

Facts

Reported
Jan 14, 2013
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees