Clique

90 - Random macros breaking in combat with Clique enabled.

  • What steps will reproduce the problem?
    1. Jan. 13 Install and enable only Clique.
    2. Jan. 13 Create /cast <class ability> macros (not Clique macros) in the Blizzard macro window, and use them in combat (most frequently LFR).
    3. Use class ability macros in combat for indeterminable time (5 seconds - 30 minutes).
    4. A class ability macro breaks.

  • What is the expected output? What do you see instead?
    The class ability macros should continue to function as normal. Instead, the individual macro breaks, and becomes unusable.
    • The button on which the macro is placed, is able to indicate clicks/presses.
    • The button on which the macro is placed, updates ability icons correctly with the corresponding ability given in the macro, depending on their modifier [alt, ctrl, shift].
    • The macro itself does not function or launch the relevant ability.

  • What version of the product are you using?
    ## Version: v50100-1.0.0
    

  • Do you have an error log of what happened?
2/13 00:14:32.306  Execution tainted by Clique while reading CliqueDialog - Interface\FrameXML\UIParent.lua:2351
2/13 00:14:32.306      securecall()
2/13 00:14:32.306      Interface\FrameXML\UIParent.lua:2391 CloseWindows()
2/13 00:14:32.306      Interface\FrameXML\UIParent.lua:2419 CloseAllWindows()
2/13 00:14:32.306      Interface\FrameXML\UIParent.lua:2405 CloseAllWindows_WithExceptions()
2/13 00:14:32.306      Interface\FrameXML\UIParent.lua:955
2/13 00:14:32.306  An action was blocked in combat because of taint from Clique - CompactPartyFrame:unusedFunc()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:160 CompactRaidFrameContainer_LayoutFrames()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:130 CompactRaidFrameContainer_TryUpdate()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:57 CompactRaidFrameContainer_OnEvent()
2/13 00:14:32.306      CompactRaidFrameContainer:OnEvent()
2/13 00:14:32.306  An action was blocked in combat because of taint from Clique - CompactPartyFrame:SetParent()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:233 CompactRaidFrameContainer_AddGroup()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:215 CompactRaidFrameContainer_AddGroups()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:174 CompactRaidFrameContainer_LayoutFrames()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:130 CompactRaidFrameContainer_TryUpdate()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:57 CompactRaidFrameContainer_OnEvent()
2/13 00:14:32.306      CompactRaidFrameContainer:OnEvent()
2/13 00:14:32.306  An action was blocked in combat because of taint from Clique - CompactPartyFrame:SetFrameStrata()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:234 CompactRaidFrameContainer_AddGroup()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:215 CompactRaidFrameContainer_AddGroups()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:174 CompactRaidFrameContainer_LayoutFrames()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:130 CompactRaidFrameContainer_TryUpdate()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:57 CompactRaidFrameContainer_OnEvent()
2/13 00:14:32.306      CompactRaidFrameContainer:OnEvent()
2/13 00:14:32.306  An action was blocked in combat because of taint from Clique - CompactPartyFrame:Show()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:241 CompactRaidFrameContainer_AddGroup()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:215 CompactRaidFrameContainer_AddGroups()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:174 CompactRaidFrameContainer_LayoutFrames()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:130 CompactRaidFrameContainer_TryUpdate()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:57 CompactRaidFrameContainer_OnEvent()
2/13 00:14:32.306      CompactRaidFrameContainer:OnEvent()
2/13 00:14:32.306  An action was blocked in combat because of taint from Clique - CompactPartyFrame:ClearAllPoints()
2/13 00:14:32.306      Interface\FrameXML\FlowContainer.lua:157 FlowContainer_DoLayout()
2/13 00:14:32.306      Interface\FrameXML\FlowContainer.lua:17 FlowContainer_ResumeUpdates()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:185 CompactRaidFrameContainer_LayoutFrames()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:130 CompactRaidFrameContainer_TryUpdate()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:57 CompactRaidFrameContainer_OnEvent()
2/13 00:14:32.306      CompactRaidFrameContainer:OnEvent()
2/13 00:14:32.306  An action was blocked in combat because of taint from Clique - CompactPartyFrame:SetPoint()
2/13 00:14:32.306      Interface\FrameXML\FlowContainer.lua:161 FlowContainer_DoLayout()
2/13 00:14:32.306      Interface\FrameXML\FlowContainer.lua:17 FlowContainer_ResumeUpdates()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:185 CompactRaidFrameContainer_LayoutFrames()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:130 CompactRaidFrameContainer_TryUpdate()
2/13 00:14:32.306      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameContainer.lua:57 CompactRaidFrameContainer_OnEvent()
2/13 00:14:32.307      CompactRaidFrameContainer:OnEvent()
2/13 00:14:32.307  An action was blocked in combat because of taint from Clique - CompactRaidFrameManagerContainerResizeFrame:Hide()
2/13 00:14:32.307      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:559 CompactRaidFrameManager_LockContainer()
2/13 00:14:32.307      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:552 CompactRaidFrameManager_UpdateContainerLockVisibility()
2/13 00:14:32.307      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:46

  • Please provide any additional information below.
    • Jan. 13 The issue started occurring after a clean wipe of the Interface and WTF folders.
      • Before the wipe, I had been using Clique (no idea which version, but it was updated for MoP) with other addons since the release of the MoP expansion, and game macros have been working fine.
      • After the wipe on January 18th 2013, possibly a few days later, I did a clean install of select addons (Clique, Engraved). I do not recall macros breaking between the periods of wiping the Interface and WTF folders, and installing Clique and Engraved.
    • A /console reloadui only resets the problem.
    • The issue can re-appear as quickly as a few seconds after a /console reloadui resetting the preceding same issue.
    • A new macro copy dragged from the /macro window onto a button will also not function if the macro is broken.
    • Jan. 13 I recall a similar issue with identical effects, which had been occurring about a little less than a year ago (spring-summer of 2012). I may have had been using Clique at that time, but I do not remember the version, and my memory is fuzzy and may even be wrong.
User When Change
Neutronimity Feb 13, 2013 at 15:31 UTC Changed description:
  * **What steps will reproduce the problem?**
- ## Create /cast <class ability> macros (not Clique macros), and use them in combat (most frequently LFR).
+ ## <<color #004CFF>>^^Jan. **13**^^<</color>> Install and enable only Clique.
+ ## <<color #004CFF>>^^Jan. **13**^^<</color>> Create /cast <class ability> macros (not Clique macros) <<color #004CFF>>in the Blizzard macro window<</color>>, and use them in combat (most frequently LFR).
  ## Use class ability macros in combat for indeterminable time (5 seconds - 30 minutes).
- ## One class ability macro breaks.
+ ## A class ability macro breaks.
  ----
----------------------------------------
  ----

  * **Please provide any additional information below.**
+ ** <<color #004CFF>>^^Jan. **13**^^<</color>> The issue started occurring after a clean wipe of the Interface and WTF folders.
+ *** Before the wipe, I had been using Clique (//no idea which version, but it was updated for MoP//) with other addons since the release of the MoP expansion, and game macros have been working fine.
+ *** After the wipe on January 18th 2013, possibly a few days later, I did a clean install of select addons (Clique, Engraved). I do not recall macros breaking between the periods of wiping the Interface and WTF folders, and installing Clique and Engraved.
  ** A /console reloadui only resets the problem.
  ** The issue can re-appear as quickly as a few seconds after a /console reloadui resetting the preceding same issue.
  ** A new macro copy dragged from the /macro window onto a button will also not function if the macro is broken.
+ ** <<color #004CFF>>^^Jan. **13**^^<</color>> I recall a similar issue with identical effects, which had been occurring about a little less than a year ago (spring-summer of 2012). I may have had been using Clique at that time, but I do not remember the version, and my memory is fuzzy and may even be wrong.
Neutronimity Feb 13, 2013 at 01:05 UTC Changed description:
  ----

- * **What is the expected output? What do you see instead?**
+ * **What is the expected output? What do you see instead?**\\
  The class ability macros should continue to function as normal. Instead, the individual macro breaks, and becomes unusable.
  ** The button on which the macro is placed, is able to indicate clicks/presses.
  ** The button on which the macro is placed, updates ability icons correctly with the corresponding ability given in the macro, depending on their modifier [alt, ctrl, shift].
Neutronimity Feb 13, 2013 at 01:00 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 5 comments
  • Avatar of furgason05 furgason05 Mar 14, 2013 at 20:51 UTC - 0 likes

    I seem to be having this issue as well, although I can only reproduce this in arena so far, haven't tried yet in bgs. Was pretty frustrating when none of my healing macros worked and my partner died from it.

  • Avatar of Cladhaire Cladhaire Feb 13, 2013 at 15:23 UTC - 0 likes

    It's a taint issue, which are incredibly difficult to reproduce and debug, don't feel bad =)

  • Avatar of Neutronimity Neutronimity Feb 13, 2013 at 15:16 UTC - 1 like

    Hello, thanks for the update!

    I have only just downloaded the new version, but I would like to add some things that I forgot to mention in the ticket. It may help with tracking down the bug, if it hasn't already been found.

    • The issue started occurring after a clean wipe of the Interface and WTF folders.
      • Before the wipe, I had been using Clique (no idea which version, but it was updated for MoP) with other addons since the release of the MoP expansion, and game macros have been working fine.
      • After the wipe on January 18th 2013, possibly a few days later, I did a clean install of select addons (Clique, Engraved). I do not recall macros breaking between the periods of wiping the Interface and WTF folders, and installing Clique and Engraved.
    • The issue occurs with only Clique enabled.
    • I recall a similar issue with identical effects, which had been occurring about a little less than a year ago (spring-summer of 2012). I may have had been using Clique at that time, but I do not remember the version, and my memory is fuzzy and may even be wrong.
  • Avatar of Cladhaire Cladhaire Feb 13, 2013 at 06:25 UTC - 0 likes

    I released an update that might reduce the chance of this.

  • Avatar of Cladhaire Cladhaire Feb 13, 2013 at 05:37 UTC - 0 likes

    This won't be a quick fix, whatever is going on here. I'll do my best.

  • 5 comments

Facts

Last updated
Feb 13, 2013
Reported
Feb 13, 2013
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees