ElvUI Chat Tweaks

63 - Error when disabling spam log again

What steps will reproduce the problem?
1. I only use a few selected options, and in particular, I don't use the SpamLog option. Whenever I turn that option off, I get this error.
2. I get an error message when using ct config
3. Happy new year!!!!!

What is the expected output? What do you see instead?

I expect to see the config menu.

What version of the product are you using?
5.71

Do you have an error log of what happened?

Message: ...nterface\AddOns\ElvUI_ChatTweaks\Modules\SpamLog.lua:163 attempt to index field 'crap' (a nil value)
Time: 01/02/13 09:49:42
Count: 1
Stack: [string "*:OnLoad"]:6: in function <[string "*:OnLoad"]:1>
[C]: ?
...nterface\AddOns\ElvUI_ChatTweaks\Modules\SpamLog.lua:163 in function `member'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:249 in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:197
(tail call): ?
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:984 in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:965
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1021 in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:999
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1675 in function `FeedGroup'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1860 in function `?'
...terface\AddOns\ElvUI_ChatTweaks\ElvUI_ChatTweaks.lua:333 in function `OpenConfig'
...terface\AddOns\ElvUI_ChatTweaks\ElvUI_ChatTweaks.lua:217 in function `?'
Interface\FrameXML\ChatFrame.lua:4388 in function `ChatEdit_ParseText'
Interface\FrameXML\ChatFrame.lua:4082 in function `ChatEdit_SendText'
Interface\FrameXML\ChatFrame.lua:4121 in function <Interface\FrameXML\ChatFrame.lua:4117
[C]: in function `ChatEdit_OnEnterPressed'
[string "*:OnEnterPressed"]:1: in function <[string "*:OnEnterPressed"]:1>

Locals: msg = nil
self = <unnamed> {
 0 = <userdata>
 origErrorHandler = <function> defined Interface\FrameXML\BasicControls.xml:<Scripts>:4
 errorHandler = <function> defined @Interface\AddOns\TradeSkillMaster\Util\ErrorHandler.lua:215
 handler = <function> defined *:OnLoad:1
}

Please provide any additional information below.

User When Change
Lockslap Jan 03, 2013 at 19:49 UTC
Gjerdesmett Jan 02, 2013 at 23:03 UTC
Lockslap Jan 02, 2013 at 21:10 UTC
Gjerdesmett Jan 02, 2013 at 08:52 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 3 comments
  • Avatar of Lockslap Lockslap Jan 03, 2013 at 19:49 UTC - 0 likes

    Ah okay, the disabling and reloading UI was the key. I finally got the same error.

    Its fixed now, thanks!

  • Avatar of Gjerdesmett Gjerdesmett Jan 02, 2013 at 23:03 UTC - 0 likes

    English locale (English client on EU-English server).

    I only get this error if I turn OFF the spam log option, reload UI and then type ct->config.

    Last edited Jan 02, 2013 by Gjerdesmett
  • Avatar of Lockslap Lockslap Jan 02, 2013 at 20:54 UTC - 0 likes

    I can't duplicate the error, I have never received any errors from the Spam Log module or any of the modules it monitors.

    What locale are you using? I suspect its a locale issue.

  • 3 comments

Facts

Last updated
Jan 03, 2013
Reported
Jan 02, 2013
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees