Genie

131 - r310 crash on bag sort

Things i need to know/ have, whithout which i can't help

Genie r310

I get the LUA error posted below on all characters when I do /genie work on my local bags.

I have tried with a test character running only Genie (not LDB or GUI modules) with just a hearthstone and tough jerky in my backpack and I get the same result.

Message: Interface\AddOns\Genie\Genie.lua:4333: bad argument #1 to 'find' (string expected, got nil)
Time: Wed Dec 19 20:50:41 2012
Count: 2
Stack: [C]: in function `find'
Interface\AddOns\Genie\Genie.lua:4333: in function `New'
Interface\AddOns\Genie\Genie.lua:2108: in function `?'
Interface\AddOns\Genie\Genie.lua:2538: in function `TheWorks'
Interface\AddOns\Genie\Genie.lua:2023: in function `?'
Interface\AddOns\Genie\Genie.lua:2538: in function <Interface\AddOns\Genie\Genie.lua:2528>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
(tail call): ?
...face\AddOns\Genie\Libs\AceTimer-3.0\AceTimer-3.0.lua:164: in function <...face\AddOns\Genie\Libs\AceTimer-3.0\AceTimer-3.0.lua:138>

Locals: <none>
User When Change
adjo Dec 22, 2012 at 13:16 UTC
jasonolive Dec 22, 2012 at 01:08 UTC
adjo Dec 20, 2012 at 07:39 UTC
jasonolive Dec 20, 2012 at 02:56 UTC Changed description:
  I get the LUA error posted below on all characters when I do [b]/genie work[/b] on my local bags.

- I have tried with a test character with just a hearthstone and tough jerky in my backpack and I get the same result.
+ I have tried with a test character running only Genie (not LDB or GUI modules) with just a hearthstone and tough jerky in my backpack and I get the same result.
  [code]
  Message: Interface\AddOns\Genie\Genie.lua:4333: bad argument #1 to 'find' (string expected, got nil)
jasonolive Dec 20, 2012 at 02:54 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 3 comments
  • Avatar of jasonolive jasonolive Dec 22, 2012 at 01:08 UTC - 0 likes

    It is back to working. Thank you.

  • Avatar of adjo adjo Dec 20, 2012 at 07:39 UTC - 0 likes

    r311 should fix it

  • Avatar of HellrazerXP HellrazerXP Dec 20, 2012 at 03:16 UTC - 0 likes

    I am getting the same exact error it still sorts but it will not move items after the error. Reverting till fix is made.

    Last edited Dec 20, 2012 by HellrazerXP
  • 3 comments

Facts

Last updated
Dec 22, 2012
Reported
Dec 20, 2012
Status
Verified - QA has verified that the fix has worked.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
1

Reported by

Possible assignees

  • Avatar of adjo
    • Manager
    • Author