HideRaidFrame

2 - Lua errors

Tell Ketho how to reproduce this error:

1. use the addon , no special checkboxes , random fights

Version number?

1.2

Post your error log if any (Swatter/BugSack can grab it for you)

232x [ADDON_ACTION_BLOCKED] AddOn "HideRaidFrame" tried to call the protected function "TargetFrame:originalShow()".
!BugGrabber-r198-release\BugGrabber.lua:552 in function <!BugGrabber\BugGrabber.lua:552
<in C code>
FrameXML\FrameLocks.lua:90 in function <FrameXML\FrameLocks.lua:68
FrameXML\FrameLocks.lua:103 in function <FrameXML\FrameLocks.lua:96
FrameXML\FrameLocks.lua:125 in function "Show"
FrameXML\TargetFrame.lua:105 in function "TargetFrame_Update"
FrameXML\TargetFrame.lua:154 in function "OnEvent"
FrameXML\UnitFrame.lua:663 in function <FrameXML\UnitFrame.lua:661
<in C code>
<string>:"TURNORACTION":4: in function <string>:"TURNORACTION":1

Locals:
nil

 

232x [ADDON_ACTION_BLOCKED] AddOn "HideRaidFrame" tried to call the protected function "TargetFrame:originalHide()".
!BugGrabber-r198-release\BugGrabber.lua:552 in function <!BugGrabber\BugGrabber.lua:552
<in C code>
FrameXML\FrameLocks.lua:92 in function <FrameXML\FrameLocks.lua:68
FrameXML\FrameLocks.lua:103 in function <FrameXML\FrameLocks.lua:96
FrameXML\FrameLocks.lua:121 in function "Hide"
FrameXML\TargetFrame.lua:103 in function "TargetFrame_Update"
FrameXML\TargetFrame.lua:154 in function "OnEvent"
FrameXML\UnitFrame.lua:663 in function <FrameXML\UnitFrame.lua:661

Locals:
nil

sorry if double posted this on Curse.com comments aswell :p

User When Change
Ketho May 06, 2014 at 15:39 UTC Changed status from New to Fixed
reaper666735 Jan 11, 2014 at 18:16 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of reaper666735 reaper666735 Jan 18, 2014 at 17:35 UTC - 0 likes

    so far so good , haven't gotten any Raid frame error for about a week now since i re-enabled the Hard Disable option :) , i guess you can close the ticket as " Solved " :p , should there be any other errors il just make a fresh ticket :) , ty again for the help

  • Avatar of Ketho Ketho Jan 12, 2014 at 07:24 UTC - 0 likes

    Yeah, if you want to use the "Raid Style Party Frames" then it won't work. But afaik the normal party frames should still work.

    The Hard Disable should definitely solve all taint problems if you keep getting taint errors, so yes you will have to use that...

    The warning is that any other addons that also try to disable or alter the Raid Frames will give errors.

  • Avatar of reaper666735 reaper666735 Jan 11, 2014 at 23:15 UTC - 0 likes

    by special checkboxes i meant Raid Manager / Raid Container and ofc Hard disable are not checked :p ,

    i disabled it times ago with the previous problem of the Party frames not showing up with Hard Disable , never checked it again tbh lol ,

    i guess i will have to use it ? ,

    ow and there is a warning about using it could interfere with other addons , what kind of trouble do you mean ? or types of addons maybe since i use a phew

  • Avatar of Ketho Ketho Jan 11, 2014 at 20:35 UTC - 0 likes

    Hey reaper666735, are you using the "Hard Disable" (default) option? What do you mean with "no special checkboxes"?

    Yeah, I noticed you doubleposted in the curse.com comments =) I don't think I can fix anything with these taint errors though ><

  • 4 comments

Facts

Last updated
May 06, 2014
Reported
Jan 11, 2014
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees