Hydra - Multibox Leveling Helper

17 - RealID forwarding

Hydra version:

5.0.4.82

WoW version and region/language:

Check the WoW login screen if you’re not sure!

NA

Description of the problem:

Chat forwarding does not include RealID chat.

Steps to reproduce the problem:

1.n/a
2.
3.

Does the problem still happen when all other addons are disabled?

Yes

Exact text of the first related error message, if any:

n/a

Screenshot, if the problem is graphical:

n/a

Anything else you think might be helpful:

RealID chat is currently not forwarded with this addon. Regular whispers are. There is another multibox addon package that does include this functionality but I'd prefer to use this one, and using the two together simply for the chat forwarding is causing issues with group invites, so I'd prefer to use only one. There is no standalone addon for this functionality that I've found.

I feel this would help a lot with the issue plaguing multboxing, and that is RealID messages being sent to a slave toon. It's annoying.

User When Change
Phanx Dec 12, 2014 at 00:47 UTC Changed status from Accepted to Invalid
Phanx Nov 08, 2012 at 07:28 UTC
Phanx Oct 22, 2012 at 12:21 UTC
Phanx Oct 22, 2012 at 07:51 UTC Changed description type from Plain Text to Markdown

Changed description:
-

  #### **Hydra version:**
  5.0.4.82
Phanx Oct 22, 2012 at 07:51 UTC
eq2imora Sep 10, 2012 at 21:02 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 7 comments
  • Avatar of Phanx Phanx Dec 12, 2014 at 00:47 UTC - 0 likes

    Issue tracking moved to https://github.com/Phanx/Hydra/issues

  • Avatar of Phanx Phanx Oct 22, 2012 at 12:20 UTC - 0 likes

    Try the attached file. It should (theoretically) forward Battle.net whispers and conversations to the master character, as long as the master character is also on an account that is Battle.net friends with the sender. Forwarded Battle.net messages should appear, and can be responded to, as if they were received normally.

    As I don't have two WoW accounts under a single Battle.net account, I can't actually test this, so please let me know whether it works. If it does not, please post any related error messages you get from BugSack.

    Name Description Size MD5
    Hydra-r92.zip Hydra r92-alpha 145.1 KiB 602740497316...
  • Avatar of eq2imora eq2imora Sep 25, 2012 at 04:51 UTC - 0 likes

    Message: Interface\FrameXML\ChatFrame.lua:4420: bad argument #1 to 'strsub' (string expected, got nil) Time: 09/24/12 21:49:25 Count: 1 Stack: [C]: in function `strsub' Interface\FrameXML\ChatFrame.lua:4420: in function `ChatEdit_ExtractTellTarget' Interface\FrameXML\ChatFrame.lua:4232: in function <Interface\FrameXML\ChatFrame.lua:4227> (tail call): ? Interface\FrameXML\ChatFrame.lua:4347: in function `ChatEdit_ParseText' Interface\FrameXML\ChatFrame.lua:4214: in function `ChatEdit_OnTextSet' [string "*:OnTextSet"]:1: in function <[string "*:OnTextSet"]:1> [C]: in function `SetText' Interface\FrameXML\ChatFrame.lua:3682: in function `ChatEdit_OnUpdate' [string "*:OnUpdate"]:1: in function <[string "*:OnUpdate"]:1>

    Locals: (*temporary) = nil (*temporary) = 1 (*temporary) = 1 (*temporary) = "string expected, got nil"

    Not sure which addon, if any would be doing it. I'm not using the default chat either. I'm using yours, PhanxChat.

  • Avatar of Phanx Phanx Sep 24, 2012 at 03:02 UTC - 0 likes

    I don't actually use that addon, but not being able to hit Enter means an error is occuring. Enable Lua errors under Interface Options > Help to see what the problem is.

    Last edited Sep 24, 2012 by Phanx
  • Avatar of eq2imora eq2imora Sep 17, 2012 at 20:27 UTC - 0 likes

    Edit: just tried actually using that addon. It doesn't work. "Whisper <character> doesn't actually *do* anything. In fact, it won't let me hit Enter to send text. /sigh

    Stuck using two box addons in order to have forwarded chat sucks :(

  • Avatar of eq2imora eq2imora Sep 16, 2012 at 19:27 UTC - 0 likes

    There's no information on how that addon works, and from what I'm gathering the person sending the whispers needs to have the addon installed.

    I have it installed myself, but I still have to use jamba to forward them, and that addon doesn't play nicely with this one resulting in my having to disable one or the other to form a party(it auto disbands every time I do :( )

    The way Jamba works apparently is to sent RealID whispers to the master character via whispers, say my druid gets a realID whisper, she in turn copies the message in a whisper to my warrior who I'm actively controlling.

    If you know exactly how that addon's supposed to work, let me know, but it appears to do nothing for me and I haven't found any settings for it.

  • Avatar of Phanx Phanx Sep 11, 2012 at 21:46 UTC - 0 likes

    I don't use Real ID, but I'll see what I can do.

    Edit: If all of your characters are on one Battle.net account, this addon should solve the problem for you:
    http://wow.curseforge.com/addons/realid-toons-fix/

    Last edited Sep 11, 2012 by Phanx
  • 7 comments

Facts

Last updated
Dec 12, 2014
Reported
Sep 10, 2012
Status
Invalid - This was not a valid report.
Type
Enhancement - A change which is intended to better the project in some way
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees