ImpIgnore

36 - ElvUI / Impignore clash causing "world" channels to break and not display

General ( trade etc ) channels not displaying with current updates of ELVUI and Impignore, all non /1 /2 /3 etc work fine ( party / raid / RW / say / whisper etc ). if impignore disabled and UI reloaded alll /1 etc channels work flawlessly. ticket raised with elvui team too in case it's not your addon but a bad hook/rpc on their end instead

What steps will reproduce the problem?
1. have elvui installed
2. have impignore installed too
3. enter game

What is the expected output? What do you see instead?

expected outcome is general / trade / LD / LFG split over 2 windows or in same panel and working.

Actual is no displaying of general / trade / LD / LFG until impignore disabled and UI reloaded

What version of the product are you using?

v201210251506 for impignore, 6.99995 for elvui

Do you have an error log of what happened?

think this is it, may not be but is only error from chat from before i removed impignore to sort problem

30x FrameXML\HistoryKeeper.lua:26 bad argument #1 to "strlower" (string expected, got boolean)
<in C code>
FrameXML\HistoryKeeper.lua:26 in function "ChatHistory_GetAllAccessIDsByChanSender"
FrameXML\FloatingChatFrame.lua:809 in function "FCF_RemoveAllMessagesFromChanSender"
FrameXML\ChatFrame.lua:2778 in function "ChatFrame_SystemEventHandler"
ElvUI-6.99993\modules\chat\chat-Chat.lua:1204 in function <ElvUI\modules\chat\chat.lua:1200
<in C code>
FrameXML\StaticPopup.lua:941 in function "OnAccept"
FrameXML\StaticPopup.lua:3854 in function "StaticPopup_OnClick"
<string>:"*:OnClick":1: in function <string>:"*:OnClick":1

Locals:
chanSender = "0x0600000006FF8A93"
results = <table> {
}
(for generator) = <function> defined =[C]:-1
(for state) = <table> {
 2 = "0x0600000006FE4384"
 3 = "0x0600000006FE5412"
 5 = "0x0600000006F47B77"
 6 = "0x0600000006FCD0BE"
 7 = "0x0600000006FE20C3"
 8 = "0x0600000006FA5130"
 9 = false
 10 = "0x0600000006FEF22B"
 11 = "0x0600000006FE12E3"
 12 = "0x0600000006FC9EA5"
 13 = "0x0600000006FC83F4"
 14 = "0x0600000006EAA4A1"
 15 = "0x0600000006FA03D7"
 16 = "0x0600000006FE12C3"
 17 = "0x0600000006FDD5FD"
 18 = "0x0600000006FC561E"
 23 = "0x0600000006FD6F07"
 24 = "0x0600000006FDD615"
 25 = "0x0600000006FDC0F4"
 26 = "0x0600000006FF8A93"
}
(for control) = 9
accessID = 9
sender = false
accessIDToChanSender = <table> {
 2 = "0x0600000006FE4384"
 3 = "0x0600000006FE5412"
 5 = "0x0600000006F47B77"
 6 = "0x0600000006FCD0BE"
 7 = "0x0600000006FE20C3"
 8 = "0x0600000006FA5130"
 9 = false
 10 = "0x0600000006FEF22B"
 11 = "0x0600000006FE12E3"
 12 = "0x0600000006FC9EA5"
 13 = "0x0600000006FC83F4"
 14 = "0x0600000006EAA4A1"
 15 = "0x0600000006FA03D7"
 16 = "0x0600000006FE12C3"
 17 = "0x0600000006FDD5FD"
 18 = "0x0600000006FC561E"
 23 = "0x0600000006FD6F07"
 24 = "0x0600000006FDD615"
 25 = "0x0600000006FDC0F4"
 26 = "0x0600000006FF8A93"
}

Please provide any additional information below.

ticket sent to elvui team in case it's a bad hook/call on their end. used addon manager to isolate which addon was conflicting, threw up impignore. then reloaded with elvui core and impignore only, caused same conflict. reloaded with full list that used to be fine, same conflict. reloaded with same list minus impignore, "world" channels back again

impignore currently disabled, hopefully this can get sorted as it's a wonderful addon for me

User When Change
egingell Sep 04, 2014 at 01:54 UTC Changed status from New to Invalid
Madlampy Aug 26, 2014 at 10:58 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of Madlampy Madlampy Aug 28, 2014 at 13:43 UTC - 0 likes

    cheers for the reply, means it must be something ElvUI side then as that is the only error thrown by system apart from usual wow-pro bad calls (which never caused problems before apart from WoW-pro functionality) since they started clashing after last ELVUI update.

    feel free to mark this resolved and I'll chase the ElvUI guys to see if it's something they're either unaware of or in process for debugging/fixing.

    hopefully will get sorted as it's a wonderful addon for someone like me who has many alts and as a GM often has to hop characters a fair bit.

  • Avatar of egingell egingell Aug 28, 2014 at 12:35 UTC - 1 like

    Unless you fix it, it's not going to get fixed. The error message you supplied doesn't even reference any files in my addon, so I can't even attempt to blind-debug the conflict, if any.

  • 2 comments

Facts

Last updated
Sep 04, 2014
Reported
Aug 26, 2014
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees