LUI Core

298 - Game crashes after LUI error

What steps will reproduce the problem?
1. Opening the map
2.
3.

What is the expected output? What do you see instead?
Swatter catches this...then game crashes

Date: 2013-11-09 12:37:34
ID: 1
Error occured in: AddOn: LUI
Count: 1
Message: Error: AddOn LUI attempted to call a forbidden function (IsDisabledByParentalControls()) from a tainted execution path.
Debug:
   [C]: IsDisabledByParentalControls()
   ..\FrameXML\MainMenuBarMicroButtons.lua:229 UpdateMicroButtons()
   ..\FrameXML\WorldMapFrame.lua:272
      ..\FrameXML\WorldMapFrame.lua:255
   [C]: ?
   [C]: Show()
   ..\FrameXML\UIParent.lua:2255 ShowUIPanel()
   ..\FrameXML\UIParent.lua:2246 ToggleFrame()
   [string "TOGGLEWORLDMAP"]:1:
      [string "TOGGLEWORLDMAP"]:1
Locals:
None
AddOns:
  Swatter, v5.18.5433 (PassionatePhascogale)
  ACP, v3.4.5
  AucAdvanced, v5.18.5433 (PassionatePhascogale)
  AucFilterBasic, v5.18.5433 (PassionatePhascogale)
  AucFilterOutlier, v5.18.5433.5347(5.18/embedded)
  AucMatchUndercut, v5.18.5433.5364(5.18/embedded)
  AucStatHistogram, v5.18.5433 (PassionatePhascogale)
  AucStatiLevel, v5.18.5433 (PassionatePhascogale)
  AucStatPurchased, v5.18.5433 (PassionatePhascogale)
  AucStatSales, v5.18.5433.5376(5.18/embedded)
  AucStatSimple, v5.18.5433 (PassionatePhascogale)
  AucStatStdDev, v5.18.5433 (PassionatePhascogale)
  AucStatWOWEcon, v5.18.5433.5323(5.18/embedded)
  AucUtilAHWindowControl, v5.18.5433.5347(5.18/embedded)
  AucUtilAppraiser, v5.18.5433.5427(5.18/embedded)
  AucUtilAskPrice, v5.18.5433.5347(5.18/embedded)
  AucUtilAutoMagic, v5.18.5433.5415(5.18/embedded)
  AucUtilCompactUI, v5.18.5433.5427(5.18/embedded)
  AucUtilEasyBuyout, v5.18.5433.5427(5.18/embedded)
  AucUtilFixAH, v5.18.5433 (PassionatePhascogale)
  AucUtilItemSuggest, v5.18.5433.5417(5.18/embedded)
  AucUtilPriceLevel, v5.18.5433.5427(5.18/embedded)
  AucUtilScanButton, v5.18.5433.5403(5.18/embedded)
  AucUtilScanFinish, v5.18.5433.5347(5.18/embedded)
  AucUtilScanProgress, v5.18.5433.4979(5.18/embedded)
  AucUtilScanStart, v5.18.5433.5347(5.18/embedded)
  AucUtilSearchUI, v5.18.5433.5373(5.18/embedded)
  AucUtilSimpleAuction, v5.18.5433.5415(5.18/embedded)
  AucUtilVendMarkup, v5.18.5433.4828(5.18/embedded)
  Babylonian, v5.1.DEV.332(/embedded)
  Bartender4, v4.5.13.2
  Bartender4Dualspec, v
  BattlegroundTargets, v50400-1
  BeanCounter, v5.18.5433 (PassionatePhascogale)
  BetterBlizzOptions, v
  BGSpy, v1.2.6
  Configator, v5.1.DEV.344(/embedded)
  DBMCore, v
  DBMLDB, v
  DBMProfiles, v1.0.4
  DBMRaidLeadTools, v
  DBMSpellTimers, v
  DBMWorldEvents, v
  DebugLib, v5.1.DEV.337(/embedded)
  ForteCasting, v
  ForteClass, v
  ForteCooldown, v
  ForteCore, v1.980.8
  ForteHealthstone, v
  ForteSoulstone, v
  ForteSummon, v
  ForteTalent, v
  ForteTimer, v
  GatherMate2, v1.27
  Grid, v5.3.0.1621
  HealBot, v5.4.0.4
  HealBotTips, v5.4.0.4
  Informant, v5.18.5433 (PassionatePhascogale)
  LibExtraTip, v5.12.DEV.355(/embedded)
  LibRock10, v
  LUI, v3.8.0
  Overachiever, v0.73
  Postal, v3.5.1
  Prat30, v3.5.7      
  Prat30Libraries, v
  Recount, v
  SellJunk, v3.0.9
  SlideBar, v5.18.5433 (PassionatePhascogale)
  Stubby, v5.18.5433 (PassionatePhascogale)
  TipHelper, v5.12.DEV.351(/embedded)
  BlizRuntimeLib_enUS v5.4.1.50400 <us>
  (ck=9be)

User When Change
kitkeh Jan 26, 2014 at 05:18 UTC Changed status from New to Invalid
duelmaster3000 Nov 09, 2013 at 19:42 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of kitkeh kitkeh Jan 26, 2014 at 05:18 UTC - 0 likes

    IsDisabledByParentalControls() should no longer be an issue as Blizzard fixed it in 5.4.2.

  • Avatar of chaoslux chaoslux Dec 03, 2013 at 22:05 UTC - 0 likes

    IsDisabledByParentalControls is a inoffensive, yet very annoying, error caused by Blizzard that addon authors can't do anything about. It's safe to click the "Ignore" button when it tells you to "Disable LUI or Ignore" The game crashing is an entirely separate problem on your side i fear :(

  • 2 comments

Facts

Last updated
Jan 26, 2014
Reported
Nov 09, 2013
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees