NeedsUpgrade

This project has become inactive.

This project is inactive and its default file will likely not work with the most recent version of World of Warcraft. The author may have abandoned it, or it may have outlived its usefulness.

Level 90 early-heroics character

It can be a pain to remember on your character, or worse across multiple characters, which items of gear are in most need of an upgrade.

This addon is fairly simple it looks at your equipped items and colour codes each item on the character sheet. By default it uses the familiar colour scheme seen with quests and mobs etc. as follows :

Red : Item is a lot better than average items equipped
Orange : Item is better than average items equipped
Yellow : Item is around the average items equipped
Green : Item is worse than the average items equipped
White : Item is a lot worse than the average items equipped.

However due to popular demand (from forum users on MMO Champion), there are now options to reverse that scheme and make greens good, to use a colour blind friendly scheme or even to choose the colours yourself and set your own preferences.

The idea is that at a glance of your character sheet you can see which items are green and white and thus are most in need of an upgrade. This could be very useful whilst trying to get higher item levels to qualify for that next raid tier, or whilst levelling to see what gear is needing an upgrade. Also for just a general quick glance to see what you might want to spend those valor points on next.

Bear in mind that a higher item level won't be an upgrade if the stats balance is wrong for you. Know your class and your spec to know what the best balance of stats is before you consider item level. Sites like www.elitistjerks.com www.icy-veins.com and www.askmrrobot.com can assist you to work out the best stats for your character.

You must login to post a comment. Don't have an account? Register to get one!

Facts

Date created
Feb 24, 2013
Categories
Last update
Jun 14, 2013
Development stage
Inactive
License
GNU Lesser General Public License version 3 (LGPLv3)
Curse link
NeedsUpgrade
Downloads
3,465
Recent files
  • R: v1.30 for 5.3.0 Jun 14, 2013
  • A: r25 for 5.3.0 Jun 14, 2013
  • A: r24 for 5.3.0 Jun 14, 2013
  • R: v1.20 for 5.2.0 Mar 06, 2013
  • A: r22 for 5.2.0 Mar 06, 2013

Authors

Relationships

Embedded library
Ace2
Ace3
CallbackHandler-1.0
LibSharedMedia-3.0
LibStub