OPie

28 - Quick actions are not saved across reloads

What steps will reproduce the problem?
1. Creating a new ring, setting a quick action and binding the key to a button.
2. Using an old ring with a quick action already set.

What is the expected output? What do you see instead?
The quick action does not trigger when the bound key is tapped.

What version of the addon are you using?
OPie jade 3 (3.61)

Do you have an error log of what happened?
No.

Please provide any additional information below.

User When Change
foxlit Sep 21, 2012 at 00:48 UTC
foxlit Aug 29, 2012 at 19:35 UTC Changed name from Quick action not working to Quick actions are not saved across reloads
foxlit Aug 27, 2012 at 13:09 UTC
Fusyion Aug 27, 2012 at 11:45 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 6 comments
  • Avatar of foxlit foxlit Sep 21, 2012 at 00:48 UTC - 0 likes

    Fixed in Kiwi 1.

  • Avatar of foxlit foxlit Aug 27, 2012 at 23:14 UTC - 0 likes

    It's likely off by default, though there's no reason it should've changed if you've previously set it to on. I'll look into adding some indication that the global setting is off to the custom ring slice panel.

    Not selecting an allowed slice by default and not remembering the selected quick action slice across reloads are unintended changes - internals changed a bit in Jade, and suddenly nothing was saving that information. I'll probably revert it to old behavior.

    Last edited Aug 27, 2012 by foxlit
  • Avatar of Fusyion Fusyion Aug 27, 2012 at 16:32 UTC - 0 likes

    @foxlit: Go

    I don't know why, but this was unchecked. Since I didn't uncheck it manually I am assuming it happened after the update? Please correct me if I'm wrong.

    With your earlier suggestion to manually select the quick action, it now keeps working until an interface reload. The only problem now seems to be that you have to manually select it first before it remembers to use the quick action. Is this an intentional change or bug?

    Thank you again for your quick reply.

    Last edited Aug 27, 2012 by Fusyion
  • Avatar of foxlit foxlit Aug 27, 2012 at 16:26 UTC - 0 likes

    Hm, it does work for me with the previously mentioned exceptions. Could you check whether "Quick action at ring center" is checked under Behavior in /opie options?

  • Avatar of Fusyion Fusyion Aug 27, 2012 at 16:23 UTC - 0 likes

    @foxlit: Go

    Thank you for your incredibly swift response. In response:

    Even after I manually select a quick action allowed slice, it still does not select it automatically the next time. So in other words, no matter what I do, when I bring up the ring it never automatically selects the supposed quick action slice. This does not change upon restarting or reloading. I have tested it on old, existing rings and on newly created ones.

  • Avatar of foxlit foxlit Aug 27, 2012 at 13:08 UTC - 0 likes

    Could you check whether the quick action triggers correctly after you've used it by selecting the relevant slice manually?

    As I see it, there are two issues: a quick action is not pre-selected even if a ring has "Allow as quick action" slices, and the quick action selections do not persist after an interface reload. However, if you do select an "Allow as quick action" slice manually, it should be set as the ring's quick action until the next reload. Please let me know if this is not the case.

  • 6 comments

Facts

Last updated
Sep 21, 2012
Reported
Aug 27, 2012
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees