GuildCheck

24 - LuA error GuildCheck

Submitted Via

Curse Client 4.0.1.180, Microsoft Windows NT 6.0.6002 Service Pack 2

Installed Version

v 2.38

Description

Message: Interface\AddOns\GuildCheck\GuildCheck.lua:623: attempt to concatenate field 'guild' (a nil value) Time: 01/28/12 03:50:49 Count: 1 Stack: Interface\AddOns\GuildCheck\GuildCheck.lua:623: in function `ScanGuild' Interface\AddOns\GuildCheck\GuildCheck.lua:291: in function <Interface\AddOns\GuildCheck\GuildCheck.lua:291> [string "safecall Dispatcher[1]"]:4: in function <[string "safecall Dispatcher[1]"]:4> [C]: ? [string "safecall Dispatcher[1]"]:13: in function `?' ...ibs\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:92: in function `Fire' ...heck\libs\LibGuild-1.0\LibGuild-1.0\LibGuild-1.0.lua:217: in function `?' ...heck\libs\LibGuild-1.0\LibGuild-1.0\LibGuild-1.0.lua:61: in function <...heck\libs\LibGuild-1.0\LibGuild-1.0\LibGuild-1.0.lua:60> Locals: <none>

Installed Addons

Auto-Confirm Ready Check - AutoRC v1-0 AggroNotifier - AggroNotifier_1.2.6 AlarBGHelper - 4.3.1 Auto Toast - r13 Bartender4 - 4.4.20.1 BG Spy - 1.2.0 BigWigs Bossmods - r9015-release BigWigs_Citadel - r14-release BigWigs_Ragnaros_VocalLavaWave - 1.1 Buffin - v0.5-release4-4.3update Capping Battleground Timers - v4.3.002 Comergy - Comergy 1.58 Release Conjured Announcer - Conjured Announcer 1.9.9.5 Decursive - 2.7.0.4 DispelFrames - 1.3 DragEmAll - 1.0.1 EasyLogger - EasyLogger v1.0a Elkano's BuffBars - 2.3.1 - r167 EnhaPrio - v1.3.10 ezInterrupt - r40 Fast Zoom Hard - FastzoomHard 4.3.0 r3 ForteXorcist - v1.975.8 GuildCheck - v 2.38 GuildMemberStatus - v1.32-40300 Healers have to die - 1.9.1.2 Improved Loot Frame - 2.4 LUI Core - r438 Masque - r378 Masque: Darion - 4.1.2 Mutilate - Mutilate v1.14 My Equipped Item Level - My Equipped Item Level v1.0.3.40200 ncKillingBlow - ncKillingBlow NerikAlerts - NerikAlerts 1.0.3 NoFilter - NoFilter 1.0.0 Objective Announcer - v4.3.0 OmniCC - 4.3.2 PalHP - PalHP v 1.2.2 PhoenixStyle - 1.57604 PlateBuffs - 1.11.0 pNameplates - pNameplates-v1.4.0 Postal - v3.4.13 Prospect - v201108061219 PvPTimer - 2.3.1-release Raid Loot Announcer - v4 RaidAchievement - 1.088 RaidSlackCheck - 1.260 RatingBuster - 1.6.5 ReadyCheckAnnouncer - r40-release Recount - v4.3.0c release Reforgerade - r44 SexyMap - v1.2.5 Stealth Alerter - 0.99.13 TipTac - 11.09.29 TomTom - v40300-1.4.4 TooManyAddons - r34 Trick or Treat - Trick or Treat 2.5.1.zip VuhDo - VuhDo 2.133 WIM (WoW Instant Messenger) v3 - 3.5.8 wIn1 - wIn1 5.8 xUtils - xUtils YorsahjPriority - 1.2

User When Change
Jaxomuk Jan 12, 2014 at 15:44 UTC Changed status from Accepted to Duplicate
Jaxomuk Jan 30, 2012 at 10:54 UTC
eMused Jan 28, 2012 at 11:52 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of Zeglar Zeglar Oct 15, 2012 at 19:18 UTC - 0 likes

    Posting these here and on the Curse page, not sure which one you check.

    Determined the solution to the 623 error, I believe.  The problem is that ScanGuild() is called regardless of the delay you set, and that line attempts to concatenate a nil value (self:guild).  I don't know how to avoid the actual inability for the function GetGuildInfo to get the player's guild, but this solves the issue, by leaving the function early when it has bad data.  This is the diff file, with the 4 new lines (one of which is a debug line, without which this could be a single line).

    --- ./GuildCheck.lua  2012-08-30 13:19:30.000000000 -0400
    +++ /Applications/World of Warcraft/Interface/AddOns/GuildCheck/GuildCheck.lua  2012-10-15 14:52:49.000000000 -0400
    @@ -619,6 +619,10 @@
             self.updatetime = time()
             
             if not self.guild then self.guild = GetGuildInfo("player") end
    +        if not self.guild then
    +            self:Debug("ScanGuild():No Guild String, bailing...")
    +            return
    +        end
             if not self.guildstring then
                 self.guildstring = self.faction .. ":" .. self.guild
             end

    Last edited Oct 15, 2012 by Zeglar: Wrong markup, botched formatting
  • 1 comment

Facts

Last updated
Jan 12, 2014
Reported
Jan 28, 2012
Status
Duplicate - This report duplicates an existing ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees