GuildCheck

26 - event handler created which references an undefined global

What steps will reproduce the problem?

Click on Guild Check map button.

What is the expected output?

The Gui display should appear showing guild changes, if any.

What do you see instead?

the following error is thrown and the Gui does not appear.

8x GuildCheck\GuildCheck-v2.38.lua:13: attempt to index global "GuildCheckGui" (a nil value)
GuildCheck\GuildCheck-v2.38.lua:13: in function "OnClick" 
libs\LibDBIcon-1.0\LibDBIcon-1.0-24.lua:127: in function <libs\LibDBIcon-1.0\LibDBIcon-1.0.lua:127> 

Locals:
self = LibDBIcon10_GuildCheck {
 0 = <userdata>
 dataObject = <table> {}
 isMouseDown = false
 db = <table> {}
 icon = <unnamed> {}
}
b = "LeftButton"

What version of the product are you using?

2.38

Any other comments

you need to ensure that the GuildCheckGui frame is defined *before* creating the asynchronous GuildCheckLDB event handler. i believe an XML definition is the safest method, since it's guaranteed to run before the main .lua file is even looked at.

User When Change
Jaxomuk Jan 12, 2014 at 15:44 UTC Changed status from Accepted to Duplicate
Jaxomuk Mar 05, 2012 at 12:13 UTC
Speedwaystar Mar 01, 2012 at 10:32 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of Jaxomuk Jaxomuk Mar 05, 2012 at 12:11 UTC - 0 likes

    I believe that error pops if you try to open the ace gui without having use gui checked in the admin panel. Not sure you can use an XML definition with ace gui. but will look into it.

  • 1 comment

Facts

Last updated
Jan 12, 2014
Reported
Mar 01, 2012
Status
Duplicate - This report duplicates an existing ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees