GuildCheck

29 - Nil on realm enter

What steps will reproduce the problem?
1. Login
2. Wait or click on addon button near minimap

What version of the product are you using?
v2.35

Do you have an error log of what happened?
Date: 2012-09-01 21:17:58
ID: 1
Error occured in: Global
Count: 1
Message: ..\AddOns\GuildCheck\GuildCheck.lua line 13:
   attempt to index global 'GuildCheckGui' (a nil value)
Debug:
   [C]: ?
   GuildCheck\GuildCheck.lua:13 OnClick()
   ...tlasLoot_Loader\Libs\LibDBIcon-1.0\LibDBIcon-1.0.lua:131
      ...tlasLoot_Loader\Libs\LibDBIcon-1.0\LibDBIcon-1.0.lua:131
Locals:
self = LibDBIcon10_GuildCheck {
 0 = <userdata>
 dataObject = <table> {
 }
 isMouseDown = false
 db = <table> {
 }
 MBFbTex = MBFBackground {
 }
 icon = <unnamed> {
 }
 MBFoTex = MBFOverlay {
 }
}
button = "LeftButton"
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index global 'GuildCheckGui' (a nil value)"

AddOns:
  Swatter, v5.14.5335 (KowariOnCrutches)
  WowheadLooter, v50005
  NPCScan, v5.0.0.1
  NPCScanOverlay, v5.0.0.1
  NPCScanOverlayBroker, v1.2.0
  AtlasLootLoader, vv7.00.01
  AucAdvanced, v5.14.5335 (KowariOnCrutches)
  AucFilterBasic, v5.14.5335 (KowariOnCrutches)
  AucFilterOutlier, v5.14.5335.5335(5.14/embedded)
  AucMatchUndercut, v5.14.5335.5225(5.14/embedded)
  AucStatHistogram, v5.14.5335 (KowariOnCrutches)
  AucStatiLevel, v5.14.5335 (KowariOnCrutches)
  AucStatPurchased, v5.14.5335 (KowariOnCrutches)
  AucStatSales, v5.14.5335.5335(5.14/embedded)
  AucStatSimple, v5.14.5335 (KowariOnCrutches)
  AucStatStdDev, v5.14.5335 (KowariOnCrutches)
  AucStatWOWEcon, v5.14.5335.5335(5.14/embedded)
  AucUtilAHWindowControl, v5.14.5335.5133(5.14/embedded)
  AucUtilAppraiser, v5.14.5335.5335(5.14/embedded)
  AucUtilAskPrice, v5.14.5335.5160(5.14/embedded)
  AucUtilAutoMagic, v5.14.5335.5335(5.14/embedded)
  AucUtilCompactUI, v5.14.5335.5335(5.14/embedded)
  AucUtilEasyBuyout, v5.14.5335.5238(5.14/embedded)
  AucUtilFixAH, v5.14.5335 (KowariOnCrutches)
  AucUtilItemSuggest, v5.14.5335.5335(5.14/embedded)
  AucUtilPriceLevel, v5.14.5335.5237(5.14/embedded)
  AucUtilScanButton, v5.14.5335.5335(5.14/embedded)
  AucUtilScanFinish, v5.14.5335.5153(5.14/embedded)
  AucUtilScanProgress, v5.14.5335.4979(5.14/embedded)
  AucUtilScanStart, v5.14.5335.5153(5.14/embedded)
  AucUtilSearchUI, v5.14.5335.5335(5.14/embedded)
  AucUtilSimpleAuction, v5.14.5335.5208(5.14/embedded)
  AucUtilVendMarkup, v5.14.5335.4828(5.14/embedded)
  Auctionator, v3.0.1
  Babylonian, v5.1.DEV.312(/embedded)
  BeanCounter, v5.14.5335 (KowariOnCrutches)
  Configator, v5.1.DEV.330(/embedded)
  CookingHelper, v1.80
  DBMCore, v
  DBMLDB, v
  DBMSpellTimers, v
  DebugLib, v5.1.DEV.312(/embedded)
  EasyLogger, v1.0b
  Enchantrix, v5.14.5335 (KowariOnCrutches)
  EnchantrixBarker, v5.14.5335 (KowariOnCrutches)
  EnsidiaFails, v302
  EnsidiaFailsCataclysm, v2
  GatherMate2, v1.18
  GuildCheck, vv2.3.9
  GupPet, v2.102
  HealBot, v5.0.4.1
  Informant, v5.14.5335 (KowariOnCrutches)
  LibExtraTip, v5.12.DEV.324(/embedded)
  Mapster, v1.5.0
  MinimapButtonFrame, v3.1.9
  MinimapButtonFrameSkinPack, v3.0.1
  Omen, v3.1.7
  OmniCC, v5.0.1
  Overachiever, v0.66
  Postal, v3.5.0
  Prat30, v3.5      
  Prat30HighCPUUsageModules, v
  Prat30Libraries, v
  RaidRoll, v
  RaidRollEPGP, v
  RaidRollLootTracker, v
  Recount, v
  RecountEnsidiaFails, v
  RecountThreat, v
  ReforgeLite, v1.12
  Reforgerade, v0.1 r45
  ReforgeSaver, vv1.5
  SlideBar, v5.14.5335 (KowariOnCrutches)
  Stubby, v5.14.5335 (KowariOnCrutches)
  TellMeWhen, v6.0.2
  TipHelper, v5.12.DEV.315(/embedded)
  TranqShotMonitor, v
  BlizRuntimeLib_ruRU v5.0.4.50001 <eu>
  (ck=a9e)

Please provide any additional information below.
Error is gone if click show info from addon setup screen

FYI Russian translation was made by an newbie. Please update. If you need a translator - ask me.

User When Change
Jaxomuk Jan 12, 2014 at 15:44 UTC Changed status from New to Duplicate
kingoleg Sep 01, 2012 at 18:20 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of Jaxomuk Jaxomuk Oct 17, 2012 at 11:45 UTC - 0 likes

    @kingoleg: Go

    Could also just turn the GUI on in the control panel, error only shows up if u hit the GUI when it;s turned it off, which it is by default

  • Avatar of Jaxomuk Jaxomuk Oct 17, 2012 at 11:44 UTC - 0 likes

    @kingoleg: Go

    Thanks will include in next update

  • Avatar of kingoleg kingoleg Sep 01, 2012 at 18:44 UTC - 0 likes

    Updated translation:

    -- Russian Translation by StingerSoft (Eritnull aka Шептун)
    -- Updated by kingoleg <[email protected]>
    local L = LibStub("AceLocale-3.0"):NewLocale("GuildCheck", "ruRU", false)
    
    if not L then return end
    
    -- Options
    L["Use GUI"] = "Интерфейс"
    L["Defines whether the changes are diplayed in the chat or in the GUI on login."] = "Отображать изменения в окне чата или в GUI при входе в игровой мир."
    L["Output/Display only on changes"] = "Вывод/Отображение только при измeнениях"
    L["Show Text/GUI only if changes occurred."] = "Показ текста/GUI только при изменениях."
    L["Delay"] = "Задержка"
    L["Defines the seconds after login until the changes are reported."] = "Задержка в секундах, по истечению которых после входа в игру будет выведен отчёт по изменениям."
    L["<Seconds>"] = "<Секунды>"
    L["Show GUI"] = "Показать GUI"
    L["Shows a frame where you can display and copy changes."] = "Показать фрейм, где вы можете просмотреть и скопировать изменения."
    L["Show Offline Changes"] = "Показ оффлайн изменения"
    L["Offline"] = "Вне сети"
    L["Shows changes since last session."] = "Показать изменения с последней сессии."
    L["Show Online Changes"] = "Показ онлайн изменения"
    L["Online"] = "В сети"
    L["Shows changes during this session."] = "Показать изменения во время текущей сессии."
    L["Open Config"] = "Открыть настройки"
    L["Opens a graphical configuration."] = "Открыть графический настройки."
    L["Exit"] = "Выход"
    L["Shows changes in your guild since your last time online."] = "Показать изменения в вашей гильдии с прошлого вашего визита."
    L["Display"] = "Отображение"
    L["Defines what kind of changes will be shown."] = "Определение, какие изменения будут показаны."
    L["Show Promotes/Demotes"] = "Показ повышений/понижений"
    L["Show Level Ups"] = "Показ изменение уровней"
    L["Show Note Changes"] = "Показ изменений заметок"
    L["Show Officernote Changes"] = "Показ изменений офф. заметок"
    L["Members join"] = "Вступление"
    L["Show if someone has joined the guild."] = "Показать, если кто-то вступил в гильдию"
    L["Members leave"] = "Выход из гильдии"
    L["Show if someone has left the guild."] = "Показать, если кто-то вышел из гильдии"
    L["Use Guild Log"] = "Исп. журнал гильдии"
    L["Use Data from the Guild Log to show who has invited, promoted, demoted or kicked players.\n\n|cffff0000The output can lag a bit.|r"] = "Использовать данные из журнала гильдии для отображения кто вступил,повысил,понизил или исключил игроков.\n\n|cffff0000Вывод может вызвать легкое торможение.|r"
    L["Change Output Channel to Whisper"] = "Изменить канал отображения на шепот"
    L["Defines whether the changes are diplayed in the default Chat or Whisper to Player."] = "Отображать изменения в чат по-умолчанию или шептать пользователю."   
    L["Minimap Button"] = "Кнопка у миникарты"
    L["Hides Minimap Button."] = "Скрыть кнопку у миникарты."
        
    -- Output
    L["has left the guild"] = "вышел из гильдии"
    L["was removed by %s"] = "удалён %s"
    L["has joined the guild"] = "вступил в гильдию"
    L["has joined the guild (invited by %s)"] = "вступил в гильдию (пригласил %s)"
    L["was promoted by %s"] = "повысил %s"
    L["was demoted by %s"] = "понизил %s"
    L["Rank"] = "Ранг"
    L["Level"] = "Уровень"
    L["Class"] = "Класс"
    L["Note"] = "Заметка"
    L["Officernote"] = "Офицерская заметка"
    L["Initial scan done."] = "Сканирование завершено."
    L["The guild '%s' has been deleted."] = "Гильдия '%s' удалена."
    L["Total: %d changes"] = "Всего: %d изменений"
    L["Total: 1 change"] = "Всего: 1 изменение"
    L["no changes found"] = "изменений не найдено"
    L["Data upgraded to version %s!"] = "Данные обновлены до версии %s!" 
    
    -- Dialog
    L["It seems that your last character has left this guild.\nDo you want to delete the data that GuildCheck has saved for this guild?"] = "Кажется, ваш персонаж покинул гильдию.\nВы хотите удалить сохраненные данные GuildCheckа для данной гильдии?"
    L["Your GuildCheck Data needs a conversion! This process is not reversible.\nYou can choose 'No' and backup your SavedVariables folder.\nGuildCheck won't work as long as you don't convert the data.\n\nDo you want to convert the data now?"] = "Ваши данные GuildCheck нуждаются в преобразовании! Этот процесс необратим.\nВы можете выбрать 'Нет' и сделать резервную копию вашей папки SavedVariables.\nGuildCheck не будет работать, если вы не сконвертируете данные.\n\nВы хотите преобразовать данные сейчас?"
    L["Yes"] = "Да"
    L["No"] = "Нет"
    
  • Avatar of kingoleg kingoleg Sep 01, 2012 at 18:26 UTC - 0 likes

    The fix is to change 13 line of main *.lua to

    		      GuildCheck:ShowGui(true)
    
    Last edited Sep 01, 2012 by kingoleg
  • 4 comments

Facts

Last updated
Jan 12, 2014
Reported
Sep 01, 2012
Status
Duplicate - This report duplicates an existing ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees