Tidy Plates: Threat Plates

29 - Conflict with contacts/friends list

What steps will reproduce the problem?
1. Install Tidy Plates and Tidy Plates: Threat Plates as the only two addons
2. Log in and out several times on the same or other chars and click on the button for the friends list or type the standard button "o" to show the default WoW contacts list
3. In 80% of all logins you will see nothing in the list, or a very unsorted friends list (online and offline chars mixed wildly) at startup, which is updated only if friends trigger an update to this frame because of an log in/out
4. If you deactivate (at character login screen) Threat Plates, but leave the main "Tidy Plates" Addon active, everything works 100% fine. Also this positive effect was reproducable.

What is the expected output? What do you see instead?
I expect a friends list. - I see nothing.

What version of the product are you using?
6.008

Do you have an error log of what happened?
-

Please provide any additional information below.
I've tested several times (20-30 times logged in/out) and it is reproducable only for "Threat Plates" to interfer with the standard WoW friendslist.
I'm using the german client

  • 2013-05-27_16h19_50.jpg
User When Change
suicidalkatt Sep 11, 2013 at 02:53 UTC
Sascatuan Jun 03, 2013 at 08:41 UTC
suicidalkatt Jun 02, 2013 at 14:48 UTC
nobbicologne May 27, 2013 at 14:27 UTC

Added attachment 2013-05-27_16h19_50.jpg

nobbicologne May 27, 2013 at 14:24 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 9 comments
  • Avatar of mysticalos mysticalos Jul 05, 2013 at 22:44 UTC - 0 likes

    I do not believe this has anything to do with threat plates (or any other mod). This is a bug that seems to have cropped up in 5.3 and keeps getting blamed on mods but is in fact a 5.3 issue from what i've debugged. People tried to blame ara broker guild/friends for this too and i had to demonstrate to them that i was able to reproduce this problem with NO MODS INSTALLED

    This appears to be a blizzard issue where for whatever reason that frame didn't get the events (maybe the frame is created after first events are sent under the right circumstances, causing it to be blank until next BNET update event fires. i just know the issue self resolves on next event once that social frame sees them.

    the fact disabling threat plates made it go away honestly just sounds like rng. Or maybe it's possible that disabling any mod at all reduced your loading time and got that social frame created fast enough to miss the first bnet events less often.

    Last edited Jul 05, 2013 by mysticalos
  • Avatar of Sascatuan Sascatuan Jun 19, 2013 at 16:33 UTC - 0 likes

    @Lainea: Go

    thats interesting, when this issue litterally has only ever occured with this addon enabled, and never happened when its not.

  • Avatar of Lainea Lainea Jun 18, 2013 at 09:04 UTC - 0 likes

    Not sure if you sorted this issue or not, but it is actually a bug that many people are having a problem with, and is not addon related. If you click on a different tab at the bottom of the social pane and then go back to friends, your friends list should be there. Doesn't seem to be anything they're trying hard to fix atm

  • Avatar of Sascatuan Sascatuan Jun 04, 2013 at 19:34 UTC - 0 likes

    Using Tidy Plates 6.11.3 Threat plates 6.08 , fresh install, deleted all saved variables before testing, and the issue is the same, friends list remains blank until another tab is clicked such as "who" then back again. Maybe its a conflict between tidyplates and threat plates? it only seems to happen when threatplates is active, and is fine without.

    Last edited Jun 04, 2013 by Sascatuan
  • Avatar of suicidalkatt suicidalkatt Jun 04, 2013 at 13:04 UTC - 0 likes

    I can't reproduce, can you upload your saved variable files?

  • Avatar of Sascatuan Sascatuan Jun 04, 2013 at 12:54 UTC - 0 likes

    any eta on a fix?

  • Avatar of Sascatuan Sascatuan Jun 03, 2013 at 08:41 UTC - 0 likes

    I just tested this, the social widget enabled or disabled makes no difference, friends list is still bugged in the same manner, there are occasions where the list works, but 90% of the time the list is bugged.

  • Avatar of suicidalkatt suicidalkatt Jun 02, 2013 at 14:48 UTC - 0 likes

    This may be something related to the social widget.

    Try disabling it and seeing if the issues continue.

  • Avatar of Zookeeper94 Zookeeper94 Jun 02, 2013 at 13:30 UTC - 0 likes

    Having the same issue.

  • 9 comments

Facts

Last updated
Sep 11, 2013
Reported
May 27, 2013
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees