TradeSkillMaster

359 - Lua error when typing '[' in filter box

Not a part of any module.  The specific field I typed in was the Search field on the Materials tab, but it appears to apply to lots of fields throughout TSM.

Here's the error:

1x Modules\Options.lua:471 malformed pattern (missing "]")
<in C code>
Modules\Options.lua:471 in function "UpdateMatST"
Modules\Options.lua:550 in function "callback"
TradeSkillMaster-v2.0.3\GUI\BuildPage.lua:306 in function <TradeSkillMaster\GUI\BuildPage.lua:294
(tail call): ?
<in C code>
<string>:"safecall Dispatcher[3]":9: in function <string>:"safecall Dispatcher[3]":5
(tail call): ?
Ace3-Release-r1086\AceGUI-3.0\AceGUI-3.0-33.lua:314 in function "Fire"
TradeSkillMaster-v2.0.3\GUI\TSMWidgets\TSMEditBox.lua:111 in function <TradeSkillMaster\GUI\TSMWidgets\TSMEditBox.lua:107

User When Change
sapu94 Oct 19, 2013 at 19:17 UTC Changed status from New to Fixed
GraysonCarlyle Aug 10, 2013 at 17:44 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of sapu94 sapu94 Oct 19, 2013 at 19:17 UTC - 0 likes

    It's nearly impossible to fix this everywhere it could happen, but I've fixed it the area you hit in Crafting for now. If you see it elsewhere, file a new ticket.

    Lead Developer and Director of TradeSkillMaster | @Sapu94 on Twitter

    "A good programmer is someone who always looks both ways before crossing a one-way street." Doug Linder

  • 1 comment

Facts

Last updated
Oct 19, 2013
Reported
Aug 10, 2013
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees