TradeSkillMaster

397 - Tradeskill Master LUA error on Login as of 10/31/2013

Hello.

Yes I have read the below statement, however none of the other categories seem to apply to the error I am seeing upon login of any characters I own.

ATTENTION TSM USER!!!! You are currently making a ticket for the main TradeSkillMaster module which is almost certainly not the module at fault for whatever error you are experiencing. Please determine which module your issue belongs to and see if it's already been reported. If not post a ticket FOR THAT MODULE and NOT HERE otherwise your ticket will likely be closed as invalid or moved.

What steps will reproduce the problem?
1.  Logging in to any of my characters
2. see 1
3. see 1

What is the expected output? What do you see instead?

This is the error upon login:

Date: 10/31/13 11:45:48
Message:  ...terface\AddOns\TradeSkillMaster\TradeSkillMaster.lua:221 attempt to index field 'API' (a nil value)
Stack:
TSM\TSM.lua:221 <RegisterModule>
TSM\TSM.lua:138 <TradeSkillMaster.lua:121
[string "safecall Dispatcher[1]"]:9: <[string "safecall Dispatcher[1]"]:5>
...AddOns\HandyNotes\Libs\AceAddon-3.0\AceAddon-3.0.lua:529 <InitializeAddon>
...AddOns\HandyNotes\Libs\AceAddon-3.0\AceAddon-3.0.lua:644 <AceAddon-3.0.lua:636
Locale: enUS
Addons:
    Auc-Advanced (5.18.5433 (PassionatePhascogale))
    BeanCounter (5.18.5433 (PassionatePhascogale))
    Grail (057)
    Grail-Achievements (007)
    Grail-Reputations (006)
    Grail-When (001)
    GuildGreet (5.4.2)
    HandyNotes (v1.2.1)
    HandyNotes_LostAndFound (v8)
    Healers-Have-To-Die (2.2.1)
    Informant (5.18.5433 (PassionatePhascogale))
    Recount (v5.4.0a release)
    Stubby (5.18.5433 (PassionatePhascogale))
    Wholly (039)
    WoWDBProfiler (5.4.0-3)
    +Wowhead_Looter (50014)
    TSM (v2.2.4)
    TSM_Crafting (v2.4.1)
    TSM_ItemTracker (v2.0.6)
    TSM_WoWuction (v2.0.5)
    DBM-Core (5.4.4)
    ZygorGuidesViewer (4.0)

What version of the product are you using?

Version 2.2.4 updated on 10/28/2013

Do you have an error log of what happened?

Date: 10/31/13 11:45:48
Message:  ...terface\AddOns\TradeSkillMaster\TradeSkillMaster.lua:221 attempt to index field 'API' (a nil value)
Stack:
TSM\TSM.lua:221 <RegisterModule>
TSM\TSM.lua:138 <TradeSkillMaster.lua:121
[string "safecall Dispatcher[1]"]:9: <[string "safecall Dispatcher[1]"]:5>
...AddOns\HandyNotes\Libs\AceAddon-3.0\AceAddon-3.0.lua:529 <InitializeAddon>
...AddOns\HandyNotes\Libs\AceAddon-3.0\AceAddon-3.0.lua:644 <AceAddon-3.0.lua:636
Locale: enUS
Addons:
    Auc-Advanced (5.18.5433 (PassionatePhascogale))
    BeanCounter (5.18.5433 (PassionatePhascogale))
    Grail (057)
    Grail-Achievements (007)
    Grail-Reputations (006)
    Grail-When (001)
    GuildGreet (5.4.2)
    HandyNotes (v1.2.1)
    HandyNotes_LostAndFound (v8)
    Healers-Have-To-Die (2.2.1)
    Informant (5.18.5433 (PassionatePhascogale))
    Recount (v5.4.0a release)
    Stubby (5.18.5433 (PassionatePhascogale))
    Wholly (039)
    WoWDBProfiler (5.4.0-3)
    +Wowhead_Looter (50014)
    TSM (v2.2.4)
    TSM_Crafting (v2.4.1)
    TSM_ItemTracker (v2.0.6)
    TSM_WoWuction (v2.0.5)
    DBM-Core (5.4.4)
    ZygorGuidesViewer (4.0)

Please provide any additional information below.

Problems with addons slowing down FPS rates since Blizzard (World of Warcraft) Hotfix on 10/29/2013.

I have also been receiving the error "Your computer does not have enough memory to load Auction-Stat-Histogram.  Please remove some of your addons."  I believe that error belongs to Auctioneer, not Tradeskill Master, though.  My computer has plenty of memory (8GB of RAM) and I run an ATI Radeon 7950 GPU/Video Card.

User When Change
sapu94 Nov 02, 2013 at 01:13 UTC Changed status from Replied to Declined
Silmarylle Nov 01, 2013 at 14:42 UTC Changed status from Waiting to Replied
sapu94 Nov 01, 2013 at 03:30 UTC Changed status from New to Waiting
Silmarylle Oct 31, 2013 at 17:02 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 5 comments
  • Avatar of Silmarylle Silmarylle Nov 01, 2013 at 16:43 UTC - 0 likes

    Hello,

    As mentioned below, I removed both addon applications. Logged in, no errors. No change in FPS either, but that's not the subject at hand here.

    I have found that I've become VERY dependent on both TSM and Auctioneer. TSM was updated on 10/28/2013 it seems, whereas Auctioneer hasn't been updated since 9/11/2013. This is probably where the API interference/error came in when the latest Blizzard hotfix was released.

    I reinstalled both the TSM addon, and the TSM desktop application. Logged in, worked like a charm.

    Although TSM_Wowuction and TSM_AuctionDB give me the competitive pricing information I need to post my Auctions, I missed the Appraiser option from Auctioneer. I checked the Auctionator website to compare, and it hasn't been updated since 9/11/2013 either. So I re-installed the Auctioneer to be able to spend less time posting my Auctions (using TSM as well).

    After setting up the TSM Desktop app and re-registering everything, then performing the Auctioneer addon install ...No more errors upon login. I can live with that. :)

    You were right. I believe Auctioneer (possibly both TSM and Auctioneer) were only loading partially, and possibly uninstalling/reinstalling both addons seems to have fixed that issue. Prior to re-install of either addon, I checked my Interface, Cache, and WTF folders for any traces of the uninstalled addons first, so to remove any files left behind so that they wouldn't interfere with a fresh addon install.

    Thanks for responding, and hopefully my information helps someone else.

  • Avatar of Silmarylle Silmarylle Nov 01, 2013 at 14:42 UTC - 0 likes

    Thanks. Will do that today and post results here.

  • Avatar of sapu94 sapu94 Nov 01, 2013 at 03:30 UTC - 1 like

    Let me know if this solves the issue or not.

    Lead Developer and Director of TradeSkillMaster | @Sapu94 on Twitter

    "A good programmer is someone who always looks both ways before crossing a one-way street." Doug Linder

  • Avatar of sapu94 sapu94 Nov 01, 2013 at 03:30 UTC - 1 like

    The TSM error is a direct result of Auctioneer loading partially. I'd suggest clearing out your saved variables for Auctioneer or disabling it. Nothing TSM can do about this as WoW has killed off part of Auctioneer, yet it's still showing as loaded.

  • Avatar of Silmarylle Silmarylle Oct 31, 2013 at 17:26 UTC - 0 likes

    The error seems to have disabled the Auction tools I normally use as well within Tradeskill Master. I am back to default values within the game, and TSM does not show up in the addon list when going to Game Menu -> Interface, nor shows up as configureable (like it did previously) within the Auction interface at the Auctioneers.

    I have currently disabled the addon until I find a solution or a workaround is received.

  • 5 comments

Facts

Last updated
Nov 02, 2013
Reported
Oct 31, 2013
Status
Declined - We decided not to take action on this ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees