TradeSkillMaster

422 - Cannot resume dead coroutine

What steps will reproduce the problem?
1.  Logging into the Game.

What is the expected output? What do you see instead?

Expected - Nothing,

 Seeing:

Date: 2014-03-02 10:22:43
ID: 2
Error occured in: Global
Count: 1
Message: ..\AddOns\TradeSkillMaster\Core\Threading.lua line 28:
   cannot resume dead coroutine
Debug:
   [C]: ?
   [C]: error()
   TradeSkillMaster\Core\Threading.lua:28 callback()
   TradeSkillMaster\Util\Delay.lua:30
      TradeSkillMaster\Util\Delay.lua:18
Locals:

AddOns:
  Swatter, v4.4.1 (<%codename%>)
  TradeSkillMaster, vv2.5.4
  TradeSkillMasterAccounting, vv2.2.15
  TradeSkillMasterAdditions, vv2.1.1
  TradeSkillMasterAuctionDB, vv2.3.10
  TradeSkillMasterAuctioning, vv2.3.1
  TradeSkillMasterCrafting, vv2.4.6
  TradeSkillMasterDestroying, vv2.1.1
  TradeSkillMasterItemTracker, vv2.0.7
  TradeSkillMasterMailing, vv2.1.5
  TradeSkillMasterShopping, vv2.3.4
  TradeSkillMasterWarehousing, vv2.0.10
  TradeSkillMasterWoWuction, vv2.0.5

What version of the product are you using?

2.5.4

Do you have an error log of what happened?

See above, but I also have the below error happen at the same time:

Date: 2014-03-02 10:22:43
ID: 1
Error occured in: Global
Count: 1
Message: [string "..\FrameXML\BasicControls.xml:<Scrip"] line 18:
   attempt to call global 'ScriptErrorsFrame_OnError' (a nil value)
Debug:
   debugstack error :memory allocation error: block too big
Locals:

AddOns:
  Swatter, v4.4.1 (<%codename%>)
 

Please provide any additional information below.

this has been happening for the last few days, that I know of.

User When Change
sapu94 May 11, 2014 at 20:56 UTC Changed status from Replied to Declined
sapu94 May 11, 2014 at 20:56 UTC Changed status from Waiting to Replied
sapu94 Mar 03, 2014 at 00:40 UTC Changed status from Replied to Waiting
blanckaert Mar 02, 2014 at 23:15 UTC Changed status from Waiting to Replied
sapu94 Mar 02, 2014 at 17:35 UTC Changed status from New to Waiting
blanckaert Mar 02, 2014 at 15:32 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of sapu94 sapu94 May 11, 2014 at 20:56 UTC - 0 likes

    Closing since this hasn't been seen in a while.

    Lead Developer and Director of TradeSkillMaster | @Sapu94 on Twitter

    "A good programmer is someone who always looks both ways before crossing a one-way street." Doug Linder

  • Avatar of blanckaert blanckaert Mar 02, 2014 at 23:39 UTC - 0 likes

    ok.. .went back and disabled and re enabled all TSM one at a time, then just had auctionDB and wowauction parts turned off, and received no errors.

    Then turned on just auctionDB, no error, turned wowuction on, and got the error.

    turned auctionDB off, and left wowuction on - no error, now, turned back on, and this time no error at the moment.

  • Avatar of blanckaert blanckaert Mar 02, 2014 at 23:15 UTC - 0 likes

    ok, so which TSM Module is causing the TSM CORE, to through the error, or do you mean it could be a conflict with another addon ?

  • Avatar of sapu94 sapu94 Mar 02, 2014 at 17:35 UTC - 0 likes

    You'll need to narrow down exactly what combination of modules causes the error.

  • 4 comments

Facts

Last updated
May 11, 2014
Reported
Mar 02, 2014
Status
Declined - We decided not to take action on this ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees