TradeSkillMaster

425 - Error on Looting

ATTENTION TSM USER!!!! You are currently making a ticket for the main TradeSkillMaster module which is almost certainly not the module at fault for whatever error you are experiencing. Please determine which module your issue belongs to and see if it's already been reported. If not post a ticket FOR THAT MODULE and NOT HERE otherwise your ticket will likely be closed as invalid or moved.

What steps will reproduce the problem?
1. Looting
2.
3.

What is the expected output? What do you see instead?

N/A
What version of the product are you using?

2.2.15
Do you have an error log of what happened?

Please provide any additional information below.
Addon: TradeSkillMaster
Message:  ...erface\AddOns\TradeSkillMaster\Core\ErrorHandler.lua:360 script ran too long
Date: 03/08/14 12:58:52
Client: 5.4.7
Locale: enUS
Stack:
[C]: <pcall>
[string "*:OnLoad"]:4: <[string "*:OnLoad"]:1>
[string "        return function(_item)..."]:71: <[string "        return function(_item)..."]:1>
[string "        return function(_item)..."]:69: <func>
TSM_Shopping.lua:145 <TradeSkillMaster_Shopping.lua:138
TSM_Shopping\sidebar\QuickPosting.lua:102 <UpdateSTData>
TSM_Shopping\sidebar\QuickPosting.lua:12 <callback>
TSM\Util\Delay.lua:30 <Delay.lua:18
TSM Stack:
TSMAPI:GetItemValue("item:2251:0:0:0:0:0:0", "avgBuy")
TSMAPI:GetCustomPriceSourceValue("item:2251:0:0:0:0:0:0", "buyhigh")
TSMAPI:GetCustomPriceSourceValue("item:2251:0:0:0:0:0:0", "buying")
TSMAPI:GetCustomPriceSourceValue("item:2251:0:0:0:0:0:0", "mymarket")
TSM_Shopping:GetMaxPrice("mymarket", "item:2251:0:0:0:0:0:0")
Local Variables:

TSM Event Log:

Addons:
    _NPCScan.Overlay (5.4.2.1)
    _NPCScan (5.4.2.6)
    NPCScanEx (1.2.4)
    _NPCScan.Overlay.Broker (v1.2.4)
    Altoholic (r139)
    AskMrRobot (1.2.8.0)
    BagBrother ()
    Bagnon (5.4.9)
    DataStore (r42)
    DBM-Interrupts (5.4.2)
    EnchantingShuffler (2.4)
    Farmhand (v1.6.4)
    GatherMate2 (1.27)
    Grid (5.4.1.1628)
    HealBot_br (5.4.0.6)
    HealBot_cn (5.4.0.6)
    HealBot_fr (5.4.0.6)
    HealBot_de (5.4.0.6)
    HealBot_hu (5.4.0.6)
    HealBot_it (5.4.0.6)
    HealBot_kr (5.4.0.6)
    HealBot_ru (5.4.0.6)
    HealBot_es (5.4.0.6)
    HealBot_tw (5.4.0.6)
    HealBot_Tips (5.4.7.0)
    LibSharedMedia-3.0 (5.4.0)
    MrPlow (v10.2.11-Beta
    NugComboBar (5.2.13)
    NugComboBarGUI (5.2.13)
    QuestAnnouncer4 (1.4)
    Recount (v5.4.0b release)
    RepairBroker (5.4.0)
    RSA (v.2900)
    RSA_Options (v.2900)
    RSA_Reminders (v.2900)
    RSA_DeathKnight (v.2900)
    RSA_Druid (v.2900)
    RSA_Hunter (v.2900)
    RSA_Mage (v.2900)
    RSA_Paladin (v.2900)
    RSA_Rogue (v.2900)
    RSA_Priest (v.2900)
    RSA_Monk (v.2900)
    RSA_Warlock (v.2900)
    RSA_Warrior (v.2900)
    RSA_Shaman (v.2900)
    StoneGuardTauntCues ()
    TheUndermineJournal (2.3)
    TidyPlates (6.13.4)
    TomTom (v50400-1.0.0)
    TSM (v2.5.4)
    TSM_Accounting (v2.2.15
    TSM_Additions (v2.1.1)
    TSM_AuctionDB (v2.3.10
    TSM_Auctioning (v2.3.1)
    TSM_Crafting (v2.4.6)
    TSM_Destroying (v2.1.1)
    TSM_ItemTracker (v2.0.7)
    TSM_Mailing (v2.1.5)
    tradeskillmaster_restocker (v1.9)
    TSM_Shopping (v2.3.4)
    TSM_Warehousing (v2.0.10
    TSM_WoWuction (v2.0.5)
    ZygorGuidesViewer (4.0)

User When Change
sapu94 May 11, 2014 at 20:52 UTC Changed status from New to Invalid
Delife Mar 08, 2014 at 18:00 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of sapu94 sapu94 May 11, 2014 at 20:52 UTC - 0 likes

    @polarbear_us, That error seems totally unrelated and should be made into a separate ticket.

    As far as the issue at hand for this ticket, it seems like you have a loop somewhere in your price sources. Closing this ticket since there's nothing we can do about this.

    Lead Developer and Director of TradeSkillMaster | @Sapu94 on Twitter

    "A good programmer is someone who always looks both ways before crossing a one-way street." Doug Linder

  • Avatar of polarbear_us polarbear_us Mar 16, 2014 at 06:15 UTC - 0 likes

    this happened just after killing a celestial on the island

    Addon: TradeSkillMaster Message: ...ns\TradeSkillMaster\Libs\LibExtraTip\LibExtraTip.lua:387: Usage: GameTooltip:SetUnit("unit"[, hideStatus]) Date: 03/15/14 23:08:24 Client: 5.4.7 Locale: enUS Stack: [C]: <pcall> [string "*:OnLoad"]:4: <[string "*:OnLoad"]:1> Interface\AddOns\Auctionator\AtrErrorInspector.lua:106: <AtrErrorInspector.lua:51> TSM\Libs\LibExtraTip\LibExtraTip.lua:387: <SetUnit> Interface\FrameXML\UnitFrame.lua:408: <UnitFrame_UpdateTooltip> Interface\FrameXML\UnitFrame.lua:395: <UnitFrame.lua:382> TSM Stack:

    Local Variables: msg = " ...ns\TradeSkillMaster\Libs\LibExtraTip\LibExtraTip.lua:387: Usage: GameTooltip:SetUnit("unit"[, hideStatus])" funcnames = <table> { 1 = "SetUnit" 2 = "UnitFrame_UpdateTooltip" } funcstr = "SetUnit > UnitFrame_UpdateTooltip" looksLikeAuctionatorError = false inAtrErrorHandler = true origErrorHandler = <function> defined *:OnLoad:1 zc = <table> { msg_red = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:608 IsEnglishLocale = <function> defined @Interface\AddOns\Auctionator\AuctionatorLocalize.lua:52 msg_badErr = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:644 tallyAdd = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:1121 msg = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:737 GetArrayElemOrFirst = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:150 NumToBool = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:562 msg_color = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:614 ParseBattlePetLink = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:429 ShowHide = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:36 StringStartsWith = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:930 printmem = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:1031 round = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:602 StringContains = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:892 CopyDeep = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:1003 CheckDeferredCall = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:332 priceToMoneyString = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:841 tallyPrint = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:1133 TrimBrackets = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:974 GetArrayElemOrNil = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:165 BoolToNum = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:552 If = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:99 periodic = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:355 Min = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:69 msg_pink = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:609 SetTextIf = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:47 TrimQuotes = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:954 msg_str = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:627 ItemNamefromLink = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:471 enc64 = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:215 Val = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:58 IsBattlePetLink = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:421 StringEndsWith = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:910 printableLink = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:1018 PrintTable = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:385 StringSame = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:874 priceToString = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:805 PullItemIntoMemory = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:520 val2gsc = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:787 PrintKeysSorted = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:110 msg_ex = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:746 Negate = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:572 ClearTable = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:994 BoolToString = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:542 ItemIDfromLink = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:449 UTF8_Truncate = <function> defined @Interface\AddOns\Auctionator\zcUtils.lua:128 HSV2RGB = <function> defined @Interface\AddOns\Auctionator\zcUti TSM Event Log:

    Addons: _NPCScan.Overlay (5.4.7.1) _NPCScan (5.4.2.6) Altoholic (r139) Archy (1.8.43) AskMrRobot (1.2.8.0) AtlasLoot (v7.07.02) Auctionator (3.1.5) Bartender4 (4.5.13.2) BattlePetQualityNotifier (1.3.0) DataStore (r42) DCoords (3.03) EasyCopy (4.0) FishingBuddy (1.3b) GreenWall (1.3.6) LibSharedMedia-3.0 (5.4.0) MinimapButtonFrame (3.1.10c) MinimapButtonFrame_SkinPack (3.0.1b) MoveAnything (13.9.0) Omen (v3.1.8) OmniCC (5.4.3) OmniCC_Config () Overachiever (v0.73) GearScore (5.2.0) Postal (v3.5.1) RaidBuffStatus (5.9.0) Recount (v5.4.0b release) Scrap (12.12) Scrap_Merchant () Scrap_Options () Scrap_Spotlight () Scrap_Visualizer () WeakAuras (2.0.5) WeakAurasModelPaths (2.0.5) WeakAurasOptions (2.0.5) WeakAurasTutorials (2.0.5) Wikky (2.0) WorldBossStatus (v2.2.1) TSM (v2.5.4) TSM_Accounting (v2.2.15) TSM_AuctionDB (v2.3.10) TSM_Auctioning (v2.3.1) TSM_Crafting (v2.4.6) TSM_Destroying (v2.1.1) TSM_ItemTracker (v2.0.7) TSM_Mailing (v2.1.5) TSM_Shopping (v2.3.4) DBM-Core ()

  • 2 comments

Facts

Last updated
May 11, 2014
Reported
Mar 08, 2014
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees