TradeSkillMaster_Accounting

75 - TSM Accounting Error message

What steps will reproduce the problem?
1.I don't know.  I get these error messages all the time.
2. I don't know how it's supposed to work because it gave me error messages ever since I loaded it.
3.

What is the expected output? What do you see instead? don't know, it never worked.  

What version of the product are you using (put the actual number - never say "latest")? v2.0  (I think - I'm not even sure which module is generating the error, I'm going by the first few lines of the error log.  It would be helpful if you told us where to find out which module is the problem.  

Do you have an error log of what happened? yes
Date: 10/05/13 11:49:00
Message:  ...\AddOns\TradeSkillMaster_Accounting\Modules\data.lua:314 table index is nil
Stack:
TSM_Accounting\Modules\data.lua:314 <AddRecord>
TSM_Accounting\Modules\data.lua:119 <BuybackMerchantItem>
TSM_Accounting\Modules\data.lua:78 <data.lua:78
[C]: <BuybackItem>
Interface\FrameXML\MerchantFrame.lua:411 <MerchantItemButton_OnClick>
[string "*:OnReceiveDrag"]:1: <[string "*:OnReceiveDrag"]:1>
Locale: enUS
Addons:
    _NPCScan (5.0.0.5)
    _NPCScan.Overlay (5.0.0.3)
    _NPCScan.Overlay.Broker (v1.2.4)
    Accountant_Classic (v2.5.18
    AchievementsReminder ()
    ActionBarSaver (v2.3.2)
ACP (3.4.4)
    AdvancedTradeSkillWindow (v0.10.4
    AggroNotifier (1.3.0)
    auc-advanced-searcher-pawn (v1.5.0)
    Auc-Advanced (5.18.5433 (PassionatePhascogale))
    auc-stat-wowuction (r13)
    AutoRepair ()
    AutoVendor (v0.23
    BeanCounter (5.18.5433 (PassionatePhascogale))
    Enchantrix (5.18.5433 (PassionatePhascogale))
    Enchantrix-Barker (5.18.5433 (PassionatePhascogale))
    GatherMate2 (1.27)
    Informant (5.18.5433 (PassionatePhascogale))
    MapCoords (0.17)
    Pawn (1.8.10)
    Recount (v5.4.0 release)
    SlideBar (5.18.5433 (PassionatePhascogale))
    Stubby (5.18.5433 (PassionatePhascogale))
    !Swatter (5.18.5433 (PassionatePhascogale))
    TSM (v2.0.2)
    TSM_Accounting (v2.0)
    TSM_Additions (v2.0)
    TSM_AuctionDB (v2.0)
    TSM_Auctioning (v2.0)
    TSM_ItemTracker (v2.0)
    TSM_Mailing (v2.0)
    TSM_WoWuction (v2.0.1)

Please provide any additional information below.
Please make this reporting process easier.

User When Change
sapu94 Oct 19, 2013 at 18:54 UTC Changed status from New to Invalid
kendallzemp Oct 05, 2013 at 16:06 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of sapu94 sapu94 Oct 19, 2013 at 18:54 UTC - 0 likes

    This has probably since been fixed. Even at the time you posted this ticket, your versions were very out of date.

    Lead Developer and Director of TradeSkillMaster | @Sapu94 on Twitter

    "A good programmer is someone who always looks both ways before crossing a one-way street." Doug Linder

  • Avatar of kendallzemp kendallzemp Oct 05, 2013 at 16:07 UTC - 0 likes

    Addendum:   I was visiting a vendor right before I got this message... some items were auto-vendored.  Not sure what went wrong with it.

  • 2 comments

Facts

Last updated
Oct 19, 2013
Reported
Oct 05, 2013
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees