TradeSkillMaster_Auctioning

299 - Lua Error - making WoW Freeze

What steps will reproduce the problem?
Reproduce by posting items and trying to sort the growing list by price.

What is the expected output? What do you see instead?
The auctions were posting and after the first couple the error popped up, but the scan continued and I was able to finish posting the remainder of what I had - unsure if it actually caused anything detrimental or even if it double posted anything.

Now when it happens sometimes I can continue as normal and sometimes warcraft and my whole computer freeze. It's not a very good system and the trouble seems to be too much for it to process.

What version of the product are you using (put the actual number - never say "latest")?
TSM 1.3.2
TSM Auctioning 1.1.6
TSM Auctioning_DB 1.2
TSM Shopping 1.2.2

These were the modules currently in use at the time although I have others installed - I dearly hope it wasn't a mail error while I was posting auctions.

Do you have an error log of what happened?
Message: TradeSkillMaster_Auctioning-v1.1.6\modules\GUI.lua:992: attempt to compare number with string
Time: 06/03/12 21:59:29
Count: 4
Stack: (tail call): ?
[C]: in function `sort'
...terface\AddOns\TradeSkillMaster\Libs\lib-st\Core.lua:301: in function `SortData'
...terface\AddOns\TradeSkillMaster\Libs\lib-st\Core.lua:563: in function `SetData'
...e\AddOns\TradeSkillMaster_Auctioning\modules\GUI.lua:1188: in function `UpdateLogSTData'
...e\AddOns\TradeSkillMaster_Auctioning\modules\GUI.lua:1198: in function `UpdateSTData'
...ddOns\TradeSkillMaster_Auctioning\modules\Manage.lua:198: in function `?'
...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:147: in function <...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:147>
[string "safecall Dispatcher[3]"]:4: in function <[string "safecall Dispatcher[3]"]:4>
[C]: ?
[string "safecall Dispatcher[3]"]:13: in function `?'
...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:92: in function `SendMessage'
...Ons\TradeSkillMaster_Auctioning\modules\ScanUtil.lua:56: in function <...Ons\TradeSkillMaster_Auctioning\modules\ScanUtil.lua:56>
Interface\AddOns\TradeSkillMaster\Util\Util.lua:206: in function <Interface\AddOns\TradeSkillMaster\Util\Util.lua:198>

Locals: <none>

and second error

Message: TradeSkillMaster_Auctioning-v1.1.6\modules\GUI.lua:992: attempt to compare string with number
Time: 06/03/12 21:59:29
Count: 3
Stack: (tail call): ?
[C]: in function `sort'
...terface\AddOns\TradeSkillMaster\Libs\lib-st\Core.lua:301: in function `SortData'
...terface\AddOns\TradeSkillMaster\Libs\lib-st\Core.lua:563: in function `SetData'
...e\AddOns\TradeSkillMaster_Auctioning\modules\GUI.lua:1188: in function `UpdateLogSTData'
...e\AddOns\TradeSkillMaster_Auctioning\modules\GUI.lua:1198: in function `UpdateSTData'
...ddOns\TradeSkillMaster_Auctioning\modules\Manage.lua:198: in function `?'
...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:147: in function <...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:147>
[string "safecall Dispatcher[3]"]:4: in function <[string "safecall Dispatcher[3]"]:4>
[C]: ?
[string "safecall Dispatcher[3]"]:13: in function `?'
...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:92: in function `SendMessage'
...Ons\TradeSkillMaster_Auctioning\modules\ScanUtil.lua:56: in function <...Ons\TradeSkillMaster_Auctioning\modules\ScanUtil.lua:56>
Interface\AddOns\TradeSkillMaster\Util\Util.lua:206: in function <Interface\AddOns\TradeSkillMaster\Util\Util.lua:198>

Locals: <none>

User When Change
sapu94 Jun 10, 2012 at 21:17 UTC
sapu94 Jun 10, 2012 at 21:17 UTC
sapu94 Jun 04, 2012 at 18:26 UTC
sulhir Jun 04, 2012 at 16:52 UTC Changed name from Lua Error - nothing seems broken to Lua Error - making WoW Freeze

Changed description:
  What is the expected output? What do you see instead?
  The auctions were posting and after the first couple the error popped up, but the scan continued and I was able to finish posting the remainder of what I had - unsure if it actually caused anything detrimental or even if it double posted anything.
+
+ Now when it happens sometimes I can continue as normal and sometimes warcraft and my whole computer freeze.  It's not a very good system and the trouble seems to be too much for it to process.

  What version of the product are you using (put the actual number - never say "latest")?
  TSM 1.3.2
sulhir Jun 04, 2012 at 15:21 UTC Changed description:
  What steps will reproduce the problem?
- I'm not entirely sure how to reproduce but I had been buying items with the dealfinding option and cancelling items and posting new and reposting old items when this error popped up right as I was completing my rigging of the auction house.
+ Reproduce by posting items and trying to sort the growing list by price.

  What is the expected output? What do you see instead?
  The auctions were posting and after the first couple the error popped up, but the scan continued and I was able to finish posting the remainder of what I had - unsure if it actually caused anything detrimental or even if it double posted anything.
sulhir Jun 04, 2012 at 04:38 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of sapu94 sapu94 Jun 10, 2012 at 21:17 UTC - 0 likes

    pretty sure this has already been fixed in the alpha versions so closing

    Lead Developer and Director of TradeSkillMaster | @Sapu94 on Twitter

    "A good programmer is someone who always looks both ways before crossing a one-way street." Doug Linder

  • Avatar of sapu94 sapu94 Jun 04, 2012 at 18:26 UTC - 0 likes

    Try the latest alpha version: http://wow.curseforge.com/addons/tradeskillmaster_auctioning/files/

  • 2 comments

Facts

Last updated
Jun 10, 2012
Reported
Jun 04, 2012
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees