TradeSkillMaster_Auctioning

410 - Extremely long delay when loading fresh items

What steps will reproduce the problem?
1. Go to any place that is more than 100 yards from any vendor (e.g. The Heartlands in Valley of the Four Winds).
2. Exit WoW.
3. Delete the "Cache" directory.
4. Load WoW with TSM_Auctioning enabled.
5. Now, travel to a town and interact with a vendor who has *lots* of items (e.g. Nam Ironpaw <The Stockmaster>).

What is the expected output? What do you see instead?
- Expected: The items should display nearly instantly (including names & tooltips).
- Instead: The icon is shown on all the items, but their names and tooltips are missing and will not show up for a very long time.

What version of the product are you using (put the actual number - never say "latest")?
v1.2.21

Additional information:
This bug doesn't only affect items from vendors, but also items that you get during questing, looting, and even dungeons.  When looting, this will cause the loot frame to have a very long delay before it will show up (it will not freeze the client however).  In dungeons, this causes the loot window to not appear for at least 10 sec, and oftentimes much longer than that.  While questing, this can cause quest items to not display correctly in the bag for a very long time.  I have tested this bug over the past two days and narrowed it down to the Auctioning module of TSM.

User When Change
sapu94 Jul 28, 2013 at 22:42 UTC
Expf Nov 30, 2012 at 02:49 UTC Changed description:
  What version of the product are you using (put the actual number - never say "latest")?
  v1.2.21
+
+ Additional information:
+ This bug doesn't only affect items from vendors, but also items that you get during questing, looting, and even dungeons.  When looting, this will cause the loot frame to have a very long delay before it will show up (it will not freeze the client however).  In dungeons, this causes the loot window to not appear for at least 10 sec, and oftentimes much longer than that.  While questing, this can cause quest items to not display correctly in the bag for a very long time.  I have tested this bug over the past two days and narrowed it down to the Auctioning module of TSM.
Expf Nov 30, 2012 at 02:42 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 3 comments
  • Avatar of sapu94 sapu94 Jul 28, 2013 at 22:42 UTC - 0 likes

    Closing all 1.x tickets as 2.0 is now in public beta (via our forums).

    Lead Developer and Director of TradeSkillMaster | @Sapu94 on Twitter

    "A good programmer is someone who always looks both ways before crossing a one-way street." Doug Linder

  • Avatar of thelorn2 thelorn2 Mar 30, 2013 at 23:48 UTC - 0 likes

    I disabled this addon and it's still taking a long time (although not near as long) to look at my trade skills.

  • Avatar of thetakerfan thetakerfan Feb 17, 2013 at 23:36 UTC - 0 likes

    Been having the same problem for awhile now, just decided to look around to see if I could find anything about it and this came up. Disabling TSM and looting has no delays whatsoever.

  • 3 comments

Facts

Last updated
Jul 28, 2013
Reported
Nov 30, 2012
Status
Declined - We decided not to take action on this ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees