TradeSkillMaster_ItemTracker

17 - Nil Errors on login and item mouseover

What steps will reproduce the problem?
1.  Log on
2.  Mouse over any item.  
3.

What is the expected output? What do you see instead?

The expected outcome is to see inventory tooltips over mouseover of items.  Instead tooltips are completely gone after this bug error.  

What version of the product are you using?

According to curse these are all the most up-to-date versions

 TSM (v1.5.13
    TSM_Accounting (v1.2.3)
    TSM_AuctionDB (v1.3.15
    TSM_Auctioning (v1.2.21
    TSM_Crafting (v1.1.14
    TSM_ItemTracker (v1.2.5)
    TSM_Mailing (v1.0.10
    TSM_Shopping (v1.3.12
    TSM_Warehousing (v1.4.7)

Do you have an error log of what happened?

This is the log in error...

Date: 01/17/13 11:13:01
Message:  ...lMaster_ItemTracker\TradeSkillMaster_ItemTracker.lua:95 bad argument #1 to 'pairs' (table expected, got nil)
Stack:
[C]: <pairs>
TSM_ItemTracker.lua:95 <TradeSkillMaster_ItemTracker.lua:57
[string "safecall Dispatcher[1]"]:9: <[string "safecall Dispatcher[1]"]:5>
...s\AckisRecipeList\libs\AceAddon-3.0\AceAddon-3.0.lua:514 <InitializeAddon>
...s\AckisRecipeList\libs\AceAddon-3.0\AceAddon-3.0.lua:629 <AceAddon-3.0.lua:621
Locale: enUS
Addons:
    _NPCScan (5.0.0.5)
    _NPCScan.Overlay (5.0.0.3)
    AckisRecipeList (2.4.4)
    Altoholic (r128)
    Archy (1.8.39)
    AtlasLoot (v7.04.01
    BulkMail2Inbox (5.0)
    DataStore (r38)
    EnsidiaFails (5.103-RELEASE-LFr23)
    epgp (5.8.10)
    GemStacker (v29-release)
    HandyNotes (v1.2.0)
    HandyNotes_LostAndFound (v6)
    LibAboutPanel (1.6.0)
    oRA3 (r547)
    Postal (v3.5.1)
    Prat-3.0 (3.5.3)
    QueueSpy (1.0)
    ReforgeLite (v1.23
    Skada (1.4-8)
    XPerl (r824)
    XPerl_ArcaneBar (r824)
    XPerl_CustomHighlight (r824)
    XPerl_Options (r824)
    XPerl_PartyPet (r824)
    XPerl_Party (r824)
    XPerl_PlayerBuffs (r824)
    XPerl_PlayerPet (r824)
    XPerl_Player (r824)
    XPerl_RaidAdmin (r824)
    XPerl_RaidHelper (r824)
    XPerl_RaidMonitor (r824)
    XPerl_RaidPets (r824)
    XPerl_RaidFrames (r824)
    XPerl_TargetTarget (r824)
    XPerl_Target (r824)
    TSM (v1.5.13
    TSM_Accounting (v1.2.3)
    TSM_AuctionDB (v1.3.15
    TSM_Auctioning (v1.2.21
    TSM_Crafting (v1.1.14
    TSM_ItemTracker (v1.2.5)
    TSM_Mailing (v1.0.10
    TSM_Shopping (v1.3.12
    TSM_Warehousing (v1.4.7)
    DBM-Core (5.1.0)

This is the error from mousing over an item in my bags...

Date: 01/17/13 11:14:08
Message:  ...lMaster_ItemTracker\TradeSkillMaster_ItemTracker.lua:128 attempt to index field 'bags' (a nil value)
Stack:
TSM_ItemTracker.lua:128 <TradeSkillMaster_ItemTracker.lua:116
TSM\Util\Tooltips.lua:22 <LoadTooltip>
TSM\Util\Tooltips.lua:13 <callback>
TSM\Libs\LibExtraTip\LibExtraTip.lua:102 <LibExtraTip.lua:87
TSM\Libs\LibExtraTip\LibExtraTip.lua:148 <h>
TSM\Libs\LibExtraTip\LibExtraTip.lua:333 <LibExtraTip.lua:329
Interface\AddOns\Altoholic\Tooltip.lua:558 <Tooltip.lua:556
TSM\Libs\LibExtraTip\LibExtraTip.lua:290 <SetBagItem>
Interface\FrameXML\ContainerFrame.lua:815 <ContainerFrameItemButton_OnEnter>
[string "*:OnEnter"]:1: <[string "*:OnEnter"]:1>
Locale: enUS
Addons:
    _NPCScan (5.0.0.5)
    _NPCScan.Overlay (5.0.0.3)
    AckisRecipeList (2.4.4)
    Altoholic (r128)
    Archy (1.8.39)
    AtlasLoot (v7.04.01
    BulkMail2Inbox (5.0)
    DataStore (r38)
    EnsidiaFails (5.103-RELEASE-LFr23)
    epgp (5.8.10)
    GemStacker (v29-release)
    HandyNotes (v1.2.0)
    HandyNotes_LostAndFound (v6)
    LibAboutPanel (1.6.0)
    oRA3 (r547)
    Postal (v3.5.1)
    Prat-3.0 (3.5.3)
    QueueSpy (1.0)
    ReforgeLite (v1.23
    Skada (1.4-8)
    XPerl (r824)
    XPerl_ArcaneBar (r824)
    XPerl_CustomHighlight (r824)
    XPerl_Options (r824)
    XPerl_PartyPet (r824)
    XPerl_Party (r824)
    XPerl_PlayerBuffs (r824)
    XPerl_PlayerPet (r824)
    XPerl_Player (r824)
    XPerl_RaidAdmin (r824)
    XPerl_RaidHelper (r824)
    XPerl_RaidMonitor (r824)
    XPerl_RaidPets (r824)
    XPerl_RaidFrames (r824)
    XPerl_TargetTarget (r824)
    XPerl_Target (r824)
    TSM (v1.5.13
    TSM_Accounting (v1.2.3)
    TSM_AuctionDB (v1.3.15
    TSM_Auctioning (v1.2.21
    TSM_Crafting (v1.1.14
    TSM_ItemTracker (v1.2.5)
    TSM_Mailing (v1.0.10
    TSM_Shopping (v1.3.12
    TSM_Warehousing (v1.4.7)
    DBM-Core (5.1.0)

I alternatively get this on mouseover.  I can't figure out what triggers the 128 vs. the 293

Date: 01/17/13 11:21:59
Message:  ...AddOns\TradeSkillMaster_ItemTracker\Modules\data.lua:293 attempt to index field 'bags' (a nil value)
Stack:
TSM_ItemTracker\Modules\data.lua:293 <GetPlayerTotal>
TSM_ItemTracker.lua:121 <TradeSkillMaster_ItemTracker.lua:116
TSM\Util\Tooltips.lua:22 <LoadTooltip>
TSM\Util\Tooltips.lua:13 <callback>
TSM\Libs\LibExtraTip\LibExtraTip.lua:102 <LibExtraTip.lua:87
TSM\Libs\LibExtraTip\LibExtraTip.lua:148 <h>
TSM\Libs\LibExtraTip\LibExtraTip.lua:333 <LibExtraTip.lua:329
Interface\AddOns\Altoholic\Tooltip.lua:558 <Tooltip.lua:556
TSM\Libs\LibExtraTip\LibExtraTip.lua:290 <SetBagItem>
Interface\FrameXML\ContainerFrame.lua:815 <ContainerFrameItemButton_OnEnter>
[string "*:OnEnter"]:1: <[string "*:OnEnter"]:1>
Locale: enUS
Addons:
    _NPCScan (5.0.0.5)
    _NPCScan.Overlay (5.0.0.3)

Please provide any additional information below.

I have two separate accounts on one computer synched and they worked fine for a few days before this bug popped up in the middle of a play session.  I changed nothing, it just started happening.  I get the same errors with every mod but the TSM set turned off.

User When Change
sapu94 Jul 29, 2013 at 03:43 UTC
rtmfb Jan 17, 2013 at 16:23 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of sapu94 sapu94 Jul 29, 2013 at 03:43 UTC - 0 likes

    Closing as TSM 2.0 is now in public beta (via TSM forums).

    Lead Developer and Director of TradeSkillMaster | @Sapu94 on Twitter

    "A good programmer is someone who always looks both ways before crossing a one-way street." Doug Linder

  • Avatar of Feliciamarie Feliciamarie May 15, 2013 at 11:03 UTC - 0 likes

    I finally figured out how to fix it...well...get rid of the errors.

    I deleted my ItemTracker saved variable:

    C:\Program Files\World of Warcraft\WTF\Account\ACCTNAME\SavedVariables

    Deleted the "TradeSkillMaster_ItemTracker.lua" and "TradeSkillMaster_ItemTracker.lua.bak" files.

    Last edited May 15, 2013 by Feliciamarie
  • Avatar of spankyisme spankyisme Jan 23, 2013 at 13:59 UTC - 1 like

    While waiting for help from a mod, try manually syncing your ItemTracker betw accts once again. I found that if I reload or log out of a toon while they try to automatically share data, these errors occur. A manual sync where I don't mess with either of them until it finished sometimes resolves the issue for me (but it always returns).

    If you check your ItemTracker dropdown lists for characters and guilds, do you see duplicates of your toon/guild names with missing or replaced characters? Such as chrcter or ch)r)cter and guld or gu)ld? That's an accompanying problem I've noticed and can't seem to solve.

    Last edited Jan 23, 2013 by spankyisme
  • Avatar of rtmfb rtmfb Jan 17, 2013 at 16:24 UTC - 1 like

    To clarify in case it's needed; I get the error on both accounts.

  • 4 comments

Facts

Last updated
Jul 29, 2013
Reported
Jan 17, 2013
Status
Declined - We decided not to take action on this ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
1

Reported by

Possible assignees