TradeSkillMaster_Mailing

63 - Somtimes Buyer/Seller info lost, when i use Open All button

What steps will reproduce the problem?
1.Enable TradeSkillMaster_Mailing
2.Enable TradeskillMaster_Accounting
3. Collect more then 50 mail item with Open All button.

What is the expected output?
The successful AH gold return value with the buyer name appear in the TradeskillMaster_Accounting

What do you see instead?
Sometimes instead only a question mark appear in the buyer/seller column - As it can be seen in the attached photos...

What version of the product are you using?
1.6.4

Do you have an error log of what happened?
There is no error log, because this is imperfection.

Please provide any additional information below.
It never happens when I open up the letters one by one.

  • Open_All_Mail.1.PNG
  • Open_All_Mail.2.PNG
  • Open_All_Mail.3.PNG
  • Open_All_Mail.4.PNG
    LoadIT and the gold for the 2 ...
  • Open_All_Mail.6.PNG
  • Open_All_Mail.5.PNG
    2 items sold
User When Change
sapu94 Jul 29, 2013 at 03:43 UTC
Kaboca Jun 06, 2013 at 08:27 UTC Changed description:
+ plain$What steps will reproduce the problem?
+ 1.Enable TradeSkillMaster_Mailing
+ 2.Enable TradeskillMaster_Accounting
+ 3. Collect more then 50 mail item with Open All button.
+
+ What is the expected output?
+ The successful AH gold return value with the buyer name appear in the TradeskillMaster_Accounting
+
+ What do you see instead?
+ Sometimes instead only a question mark appear in the buyer/seller column - As it can be seen in the attached photos...
+
+ What version of the product are you using?
+ 1.6.4
+
+ Do you have an error log of what happened?
+ There is no error log, because this is imperfection.
+
+ Please provide any additional information below.
+ It never happens when I open up the letters one by one.
Kaboca Jun 06, 2013 at 08:26 UTC Changed description:
+ plain$What steps will reproduce the problem?
+ 1.Enable TradeSkillMaster_Mailing
+ 2.Enable TradeskillMaster_Accounting
+ 3. Collect more then 50 mail item with Open All button.
+
+ What is the expected output?
+ The successful AH gold return value with the buyer name appear in the TradeskillMaster_Accounting
+
+ What do you see instead?
+ Sometimes instead only a question mark appear in the buyer/seller column - As it can be seen in the attached photos...
+
+ What version of the product are you using?
+ 1.6.4
+
+ Do you have an error log of what happened?
+ There is no error log, because this is imperfection.
+
+ Please provide any additional information below.
+ It never happens when I open up the letters one by one.
Kaboca Jun 06, 2013 at 08:24 UTC

Added attachment Open_All_Mail.5.PNG

Kaboca Jun 06, 2013 at 08:21 UTC

Added attachment Open_All_Mail.6.PNG

Kaboca Jun 06, 2013 at 08:19 UTC

Added attachment Open_All_Mail.4.PNG

Kaboca Jun 06, 2013 at 08:18 UTC
sapu94 Jun 05, 2013 at 16:21 UTC
Kaboca Jun 05, 2013 at 10:38 UTC
sapu94 Jun 04, 2013 at 23:36 UTC
Kaboca Jun 04, 2013 at 18:30 UTC

Deleted attachment Open_All_Mail.1.PNG: duplicate picture

Kaboca Jun 04, 2013 at 18:28 UTC

Added attachment Open_All_Mail.3.PNG

Kaboca Jun 04, 2013 at 18:28 UTC

Added attachment Open_All_Mail.2.PNG

Kaboca Jun 04, 2013 at 18:28 UTC

Added attachment Open_All_Mail.1.PNG

Kaboca Jun 04, 2013 at 18:27 UTC

Added attachment Open_All_Mail.1.PNG

Kaboca Jun 04, 2013 at 18:27 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 8 comments
  • Avatar of sapu94 sapu94 Jul 29, 2013 at 03:43 UTC - 0 likes

    Closing as TSM 2.0 is now in public beta (via TSM forums).

    Lead Developer and Director of TradeSkillMaster | @Sapu94 on Twitter

    "A good programmer is someone who always looks both ways before crossing a one-way street." Doug Linder

  • Avatar of Kaboca Kaboca Jun 13, 2013 at 21:42 UTC - 0 likes

    @sapu94: Go

    I changed the attempt constans from 1 to 3 line 41 in TradeSkillMaster_Accounting\Modules\Data.lua

    local success = true if attempt > 3 and buyer == "" then buyer = "?" end Testing shows the changes work... so far so good.

  • Avatar of Kaboca Kaboca Jun 06, 2013 at 13:57 UTC - 0 likes

    @sapu94: Go

    Also double checked my TSM module versions: TSM: 1.6.4 Accounting 1.3.2 Mailing:1.3.1

  • Avatar of Kaboca Kaboca Jun 06, 2013 at 13:37 UTC - 0 likes

    @sapu94: Go

    Confirmed.

  • Avatar of Kaboca Kaboca Jun 06, 2013 at 08:18 UTC - 0 likes

    @sapu94: Go

    When the last tests are run, the only other addon was: LOADIT I will also do a test to be allowed only these things - without LoadIT.. As you can see, only two items sold, but the second one without buyer name again... I guess, the buyer is identical

    Last edited Jun 06, 2013 by Kaboca
  • Avatar of sapu94 sapu94 Jun 05, 2013 at 16:20 UTC - 0 likes

    It looks like you have addons other than TSM/Accounting/Mailing enabled? Did you try with ONLY TSM/Accounting/Mailing enabled?

  • Avatar of Kaboca Kaboca Jun 05, 2013 at 10:38 UTC - 0 likes

    @sapu94: Go

    It only happens when TradeSkillMaster_Mailing enabled and the open all button is used to collect mail items.

  • Avatar of sapu94 sapu94 Jun 04, 2013 at 23:36 UTC - 0 likes

    Does it happen with only TSM/Accounting/Mailing enabled?

  • 8 comments

Facts

Last updated
Jul 29, 2013
Reported
Jun 04, 2013
Status
Declined - We decided not to take action on this ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees