Numbers not showing over traits #16


Closed
  • Bacail created this issue Dec 12, 2018

    If you are sending a bug report, please include following information if relevant (if not sure, better include it):

    1. Version of AzeritePowerWeights 8.0.29

    2. Your class(es) you are having problems with ALL

    3. Your spec(s) you are having problems with ALL

    4. Are you using Default-scale or Custom scale? If you are using Custom-scale, can you paste export-string here? Default

    5. If you are looking for trait, but can't find it, did you check your settings and try again?

    6. Any errors? Copy&Paste or screenshots of error? Do you have Lua-errors on (/console scriptErrors 1)? No Errors

     

     

    Numbers for trains not showing in UI for selecting powers.  the current and total lines in upper left are there, but no numbers over the traits themselves.  tried uninstalling, deleted saved var for it, reinstall, no joy.

  • Bacail added an attachment Capture.JPG Dec 12, 2018

    Shows Issue

    Shows Issue

  • canofbutter posted a comment Dec 12, 2018

    The weights are being drawn behind the dialog since the parent frame doesn't have a strata set. 

    As a temporary fix for this, you can add

    f:SetFrameStrata("DIALOG")

    on line 69 of Core.lua on a line by itself right above f:RegisterEvent("ADDON_LOADED")

  • ahak posted a comment Dec 12, 2018

    I'm just about to step out of the door and leave for small trip and I don't have time to fix this now, please use canofbutter's fix until I get back.


    Edited Dec 12, 2018
  • Bacail closed issue Dec 12, 2018
  • Bacail posted a comment Dec 12, 2018

    ty for the response.  safe trip and ty for the great addon

  • Cyberbook added an attachment azerite.PNG Dec 12, 2018

    azerite

    @canofbutter---- so?

  • canofbutter posted a comment Dec 12, 2018

     Yes, cyberbook, that's correct.

  • schurkiburki posted a comment Dec 13, 2018

    dont work for me :(

  • canofbutter added an attachment Core.lua Dec 13, 2018

    Frame Fix

    Replace World of Warcraft\_retail_\Interface\AddOns\AzeritePowerWeights\Core.lua with this file.

  • schufirefly posted a comment Dec 13, 2018

    I just want to give a shoutout of thanks to Canofbutter for the LUA fix.. i posted the code right where you said to do it and i have my numbers back ! Big thanks ! 

     

    @AHAK.. have a great mini trip and thanks for making a great addon for filthy casuals like me.. :) 

     

     

  • ahak posted a comment Dec 14, 2018

    This should be fixed in 8.1.0

  • Reshadf posted a comment Dec 14, 2018

    @ahak it works, however if I reforge an item the stats disappear again. :) some minor bug perhaps? ( after restarting wow it works again until I reforge an item again ) 

     

    Edit: Actually after closing the window after first time, opening it again it won't show up anymore. So I think it has to do something with showing it 1x only


    Edited Dec 14, 2018
  • lightprovad posted a comment Dec 14, 2018

    8.1.0

    Score text is not visible.


    Edited Dec 14, 2018
  • ahak posted a comment Dec 14, 2018

    Reopening this as the score shows once and then won't show up again

  • ahak reopened issue Dec 14, 2018
  • ahak posted a comment Dec 14, 2018

    In version 8.1.0 I tried to make the score strings use same framestata as the trait buttons had on the AzeriteUI, but for some reason it first gives them starta HIGH and then after some time it returns MEDIUM when checking the buttons strata, but the buttons are clearly still on HIGH since they are on top of the strings. I pushed out version 8.1.1 where I hard coded the starta HIGH to the strings and it seems to be working properly so far on my tests.

  • ahak closed issue Dec 16, 2018
  • ahak posted a comment Dec 16, 2018

    Closing this as there haven't been any reports for this in couple of days.


To post a comment, please login or register a new account.