[Database][Text] Learned for different class+Another Class Can Learn #5


  • Defect
  • Verified
Closed
Assigned to toreltwiddler
  • Teliva created this issue Jul 19, 2016

    What steps will reproduce the problem?
    1. Find an item which is flagged as "Learned from another item"
    2. Mail the item to a character on the same account which cannot use the item
    3. Tooltip does not indicate learned appearance

    What is the expected output? What do you see instead?
    Expected the appearance to appear as learned

    What was the item name?  If possible please provide a screenshot of the Debug tooltip (Escape > Interface > Addons > CanIMogIt?) or the Item ID and any item modifications (upgrades, crafted level, Heroic/Mythic, etc.).
    Screenshot of tooltip comparison attached

    What was the level and class of the character you were on?
    Level 100 paladin and level 20 mage

    What version of the product are you using?
    7.0.3.11

    Do you have an error log of what happened?
    No

    Please provide any additional information below.

  • Teliva added the tags New Defect Jul 19, 2016
  • Teliva added an attachment unlearned.jpg Jul 19, 2016

    unlearned.jpg

    <p>tooltip comparison</p>

  • AmiYuy posted a comment Jul 20, 2016

    Katorok: http://mods.curse.com/addons/wow/can-i-mog-it?comment=44

    Just to be clear..

    I'm on a mage:

    One Hand mace says: Another class can learn this item

    I mail it and log onto my rogue

    It shows that I already have learned this.

    It should show I've already learned this when I'm on my mage right? I want to know if I can vendor all these junk items other classes can use but have learned.

  • AmiYuy unassigned issue from user-1202166 Jul 20, 2016
  • AmiYuy assigned issue to toreltwiddler Jul 20, 2016
  • AmiYuy removed a tag New Jul 20, 2016
  • AmiYuy added a tag Accepted Jul 20, 2016
  • AmiYuy posted a comment Jul 20, 2016

    Reproduced on my account with 109168 and 55384.

  • AmiYuy edited title Jul 20, 2016
  • AmiYuy edited title Jul 21, 2016
  • Adrian_G2 posted a comment Jul 21, 2016

    got the same bug on http://www.wowhead.com/item=31303/valanos-longbow

    on priest alt i get the message that another class can learn this item, but on hunter alt i get the message that it's already learned from another item

    I have Starbolt Longbow as learned model

    http://www.wowhead.com/item=127236/starbolt-longbow

    http://www.wowhead.com/item=27817/starbolt-longbow


    Edited Jul 21, 2016
  • AmiYuy posted a comment Jul 21, 2016

    This is caused by the API only returning items the current character can wear, which makes our "Learned from a different item" check break.

  • AmiYuy removed a tag Accepted Jul 21, 2016
  • AmiYuy added a tag Started Jul 21, 2016
  • westaiv posted a comment Jul 22, 2016

    I've been mailing transmoggable greens, blues, and purples back and forth for days now between mail, plate, and leather alts and my cloth enchanter. I had a ton of big crates and finally got through them all and anyway it was taking a while. I just realized this and came looking for a solution which there doesn't seem to be. I love the addon and just want to submit my findings if it could help the creator in any way. The gear is not specific to any certain rarity(uncommon, rare, epic), armor type(cloth, mail, leather, plate), or from which expansion it originated. On my cloth wearer I can see the correct phrase in each tooltip for whether it has been added to the collection or not. For other armor types, I've seen that it has been learned and that it hasn't. But now I'm getting down the the items which have been learned but won't show that way on a different armor type character. There are way too many to list and the only reason I caught it is because I'm getting back all one type from certain characters, such as all plate items from plate alts. I hope this helps!

  • toreltwiddler removed a tag Started Jul 24, 2016
  • toreltwiddler added a tag Fixed Jul 24, 2016
  • toreltwiddler closed issue Jul 24, 2016
  • toreltwiddler posted a comment Jul 24, 2016

    This should be working in the next release.

  • AmiYuy removed a tag Fixed Jul 25, 2016
  • AmiYuy added a tag Verified Jul 25, 2016
  • AmiYuy posted a comment Jul 25, 2016

    Fixed in 7.0.3.13.

  • AmiYuy removed a tag Verified Jul 26, 2016
  • AmiYuy added a tag Waiting Jul 26, 2016
  • AmiYuy reopened issue Jul 26, 2016
  • AmiYuy posted a comment Jul 26, 2016

    This needs the database to work properly and that will take awhile.

  • AmiYuy removed a tag Waiting Jul 26, 2016
  • AmiYuy added a tag Replied Jul 26, 2016
  • AmiYuy edited title Jul 28, 2016
  • AmiYuy posted a comment Aug 1, 2016

    More examples in Ticket 43

  • q3fuba posted a comment Aug 1, 2016

    Same here

    AddOn v7.0.3.18

    Testen on Level 100 DK and Level 100 Mage.
    This error occures on maybe Green items
    Item on my Mage:
    Item on my Mage

    Same Item on my Deathknight:
    Item on my DK

  • AmiYuy posted a comment Aug 5, 2016
  • Brudarek posted a comment Aug 27, 2016

    This problem isn't limited to items "learned from another item", it's happening on items that are just plain unlearned.

  • toreltwiddler posted a comment Aug 27, 2016

    @Brudarek: Go

    Hi Brudarek.

    Sorry, could you be more specific about the issue you are having? This ticket is in regards to the database, a feature that is not in the current (or any recent) version of the addon.

    Could you be more detailed in what is wrong, such as with a screenshot or video of the issue, preferably with the Debug Tooltip option enabled?

    Thanks.

  • AmiYuy removed a tag Replied Sep 3, 2016
  • AmiYuy added a tag Started Sep 3, 2016
  • AmiYuy posted a comment Sep 4, 2016

    Reported to Blizzard as their tooltips are wrong because of this too: http://us.battle.net/forums/en/wow/topic/20749125479

  • AmiYuy posted a comment Sep 17, 2016

    The database to fix this is available for testing in the current alpha build. Please let us know if you find any problems with it.

  • AmiYuy removed a tag Started Oct 22, 2016
  • AmiYuy posted a comment Oct 22, 2016

    Fixed with the implementation of the database in version 7.1.0.01.

  • AmiYuy added a tag Verified Oct 22, 2016
  • AmiYuy closed issue Oct 22, 2016

To post a comment, please login or register a new account.