Changing spec - ipairs #866


  • Invalid
Closed
  • _ForgeUser12714370 created this issue Nov 24, 2016

    Hi, i get following message when i change from a healer spec to shadow spec. I have different Grid settings for dps and for healer. I don't get below message when I change from my healer settings to dps settings. When I relog, everything works fine again.

     

    Any idea what is causing this message to pop up?

     

    -------------------

     

    Date: 2016-11-24 13:34:06
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ...e\AddOns\GridStatusExternals\GridStatusExternals.lua line 257:
    bad argument #1 to 'ipairs' (table expected, got nil)
    Debug:
    [C]: ipairs()
    ...e\AddOns\GridStatusExternals\GridStatusExternals.lua:257: ScanUnit()
    ...e\AddOns\GridStatusExternals\GridStatusExternals.lua:247: UpdateAllUnits()
    Grid\Status.lua:78: Reset()
    Grid\Core.lua:301: ResetModules()
    Grid\Core.lua:241: Reset()
    Grid\Status.lua:406: Reset()
    Grid\Core.lua:638: ResetModules()
    Grid\Core.lua:463: ?()
    ...nts\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:145:
    ...nts\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:145
    [string "safecall Dispatcher[3]"]:4:
    [string "safecall Dispatcher[3]"]:4
    [C]: ?
    [string "safecall Dispatcher[3]"]:13: ?()
    ...nts\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:90: Fire()
    Masque\Libs\AceDB-3.0\AceDB-3.0.lua:466: SetProfile()
    ...AddOns\Grid\Libs\LibDualSpec-1.0\LibDualSpec-1.0.lua:184: CheckDualSpecState()
    ...AddOns\Grid\Libs\LibDualSpec-1.0\LibDualSpec-1.0.lua:416:
    ...AddOns\Grid\Libs\LibDualSpec-1.0\LibDualSpec-1.0.lua:400
    Locals:
    None
    AddOns:
    Swatter, v7.0.3 (<%codename%>)
    WowheadLooter, v60014
    NPCScanOverlay, v7.1.0.1
    AngryAssignments, vv1.8.5
    AngryWorldQuests, v
    Babylonian, v5.1.DEV.332(/embedded)
    Bartender4, v4.7.4
    BattlePetBreedID, vv1.8.5
    BrokerGarrison, v2.0.8.1
    ClassTimer, v2.3.70100.1
    Configator, v5.1.DEV.406(/embedded)
    CrossRealmAssist, v0.81 beta
    DailyGlobalCheck, v
    DailyGlobalCheckGarrisonWorkOrders, v
    DailyGlobalCheckInstanceLockouts, v
    DailyGlobalCheckProfessions, v
    DailyGlobalCheckWorldBosses, v
    DailyTamerCheck, v
    DBMCore, v7.1.3
    DBMDefaultSkin, v
    DBMSpellTimers, v
    DBMStatusBarTimers, v
    eAlignUpdated, v7.1.0
    ErrorFilter, vv3.1
    ExRT, v3790
    fontain, v1.0
    Gatherer, v7.0.3
    Gnosis, vv4.63
    Grid, v7.1.0.1
    GridIndicatorCornerIcons, v60200-1
    GridIndicatorSideIcons, v60200-1
    gridstatusdungeondebuff, v1.4
    GridStatusExternals, v
    GridStatusRaidDebuff, v7.00
    GridStatusRDLegion, v7.01
    GridStatusRole, v1.8.6
    GTFO, v4.41.4
    HandyNotes, vv1.4.11
    HandyNotesLegionTreasures, v1
    IskarAssist, v
    LibSharedMedia30, v3.0-97
    MarkOfTheLegionHelper, v1.3.1
    Masque, v7.1.0
    MasqueCleanIcons, v1.4
    MasterPlanA, vA
    MikScrollingBattleText, v5.7.147
    NomiCakes, v7.1.0.2
    NPCScan, v7.1.0.2
    Omen, v3.1.12
    Overachiever, v0.98
    Paste, v1.4.10
    Pawn, v2.1.8
    PetTracker, v7.1.3
    PetTrackerBreeds, v7.1.3
    PetTrackerBroker, v
    PetTrackerConfig, v7.1.3
    PetTrackerJournal, v7.1.3
    PetTrackerSwitcher, v7.1.3
    PetTrackerUpgrades, v7.1.3
    Prat30, v3.6.19
    Prat30Libraries, v
    RaidAchievement, v
    RaidAchievementOldModules, v
    Rarity, v1.0
    RarityOptions, v
    Rematch, v4.6.0
    Scrap, v13.4
    ScrapMerchant, v
    ScrapOptions, v
    ScrapSpotlight, v13.4
    SexyMap, vv7.1.1
    ShadowedUnitFrames, vv4.1.10
    SimpleChi, v1.3e
    SimpleComboPoints, v1.6c
    SimpleHolyPower, v1.6b
    Simulationcraft, v1.5.1
    Skada, v1.5-14
    SlideBar, v7.0.3 (<%codename%>)
    StealthMissions, v1.1
    TellMeWhen, v8.2.3
    TidyPlates, v6.18.11
    TidyPlatesGraphite, v
    TidyPlatesGrey, v
    TidyPlatesNeon, v
    TidyPlatesQuatre, v
    TidyPlatesHub, v
    TidyPlatesWidgets, v
    TipTac, v16.10.27
    TipTacItemRef, v16.10.27
    TipTacTalents, v16.10.27
    Titan, v5.9.5.70100
    titansimulationcraft, vv1.0.5.70100-alpha5
    TitanBag, v5.9.5.70100
    TitanClock, v5.9.5.70100
    TitanGold, v5.9.5.70100
    TitanLocation, v5.9.5.70100
    TitanLootType, v5.9.5.70100
    TitanPerformance, v5.9.5.70100
    TitanRepair, v5.9.5.70100
    TitanVolume, v5.9.5.70100
    TitanXP, v5.9.5.70100
    WeakAuras, v2.2.2.1
    XPerlFacade, v4.0.0
    ZPerl, v5.1.4
    ZPerlArcaneBar, v
    ZPerlParty, v
    ZPerlPartyPet, v
    ZPerlPlayer, v
    ZPerlPlayerBuffs, v
    ZPerlPlayerPet, v
    ZPerlRaidAdmin, v
    ZPerlRaidFrames, v
    ZPerlRaidHelper, v
    ZPerlRaidMonitor, v
    ZPerlRaidPets, v
    ZPerlTarget, v
    ZPerlTargetTarget, v
    BlizRuntimeLib_enUS v7.1.0.70100 <none>
    (ck=b2d)

     

  • phanxaddons closed issue Nov 28, 2016
  • phanxaddons posted a comment Nov 28, 2016

    If you look at the error message, you'll see that your problem is coming from an addon named "GridStatusExternals", not from Grid. You'll need to report the problem to the author of that addon. The authors of Grid can't fix errors in other addons!


    Edited Nov 28, 2016
  • phanxaddons added a tag Invalid Nov 28, 2016

To post a comment, please login or register a new account.