ALT+T Trade skill ring set does not function. #220


Closed
  • Ookami313 created this issue Nov 27, 2018

    As of Vanilla 9, the ALT+T key bind does not function and will not open the Trade skill ring set associated with the key bind. The correct key bind (ALT+T) does show up correctly in the options menu, but pressing the combination does not currently work. It also seems that if you unbind ALT+T from the menu associated with the trade skill ring set, the addon does not allow you to rebind ALT+T back to that option, the selection stays blank. Thanks.

  • Ookami313 edited title Nov 27, 2018
  • cfxfox posted a comment Nov 27, 2018

    Can you use the default bindings UI (game menu -> bindings) to bind anything else (e.g. Jump) to ALT-T?

  • Ookami313 posted a comment Nov 27, 2018

    I cannot. I tried to rebind Jump to something else and was able to bind it to, what looks to be, any key combination except ALT+T. I even used the OPie menu and bound space and few other ALT combinations not used already to the Trade Skill ring and the ring opened with no issue. Thanks.

     

  • cfxfox posted a comment Nov 28, 2018

    There are a few more things you could try:

    • Does the issue persist with all addons except OPie disabled?
    • Can you bind anything to ALT-T with all addons disabled?
    • Reboot, quit any other applications, check if you still can't bind anything to ALT-T.

    Altogether, this sounds more like some external application (or keyboard layout) is intercepting the ALT-T key combination before it reaches WoW.

     

    There are no significant changes to OPie's binding UI in V9, so I wouldn't expect reverting to an earlier version to reliably fix this. For what it's worth, the ALT-T binding works properly for me even when using V9.

  • Ookami313 posted a comment Nov 28, 2018

    Yea, it's got to be something outside the game that is causing an issue. I disabled, OPie, enabled Opie, disabled all addons except, and even rebuilt my WTF and Interface folders with no addons and for some reason the ALT+T combination is not recognized at all. All other combinations that I tried worked, even CTRL+T, just that one combination. It's weird because I had no issue till V9, all other iterations worked and I wasn't going to say a thing thinking it might be fixed with V10 (or whatever name it is given) until I saw a post from someone else on the main addon page for OPie (www.curseforge.com/wow/addons/opie) stating they were having the same issue, and didn't see any tickets on the issue.

     

    Since you're not having any issues I'm at a loss as the cause. I'm going to assume it's just me and possibly one other having this problem, so feel free to close this ticket. I just wish there was an easy way to figure out what application is causing this issue. Anyway, thanks for your time and patients. Keep up the good work.


    Edited Nov 28, 2018
  • cfxfox posted a comment Feb 23, 2019

    (Cannot replicate; please resubmit if this re-occurs with latest version and something else is able to bind anything to ALT+T)

  • cfxfox closed issue Feb 23, 2019

To post a comment, please login or register a new account.