BfA Zuldazar:Zandalar not working for main Zuldazar map #352


  • Defect
  • Accepted
Open
Assigned to LudovicusMaior
  • GNG_Virag created this issue Jul 8, 2018

    Tried to use: /way Zuldazar 50 50 Item

    Got: Found multiple matches for zone 'Zuldazar'. Did you mean: Zuldazar:Zandalar, Atal'Dazar:Zuldazar, Breath Of Pa'ku:Zuldazar, Dazar'alor:Zuldazar, Rastakhan's Might:Zuldazar

     

    Tried to use: /way Zuldazar:Zandalar 50 50 Item

    Got: It just ignores the cmd and never tries to set a point. No info message, nothing.

     

    Tried to use: /way 50 50 Item

    Got: Works just fine

    TomTom: Added a waypoint (Item - 50.00, 50.00) in Zuldazar

     

    Bugges only for Zuldazar area. Every other BfA area works just fine. 

    I would still prefere the 1-st option, but if nothig can be done, then 2-nd options should be fixed.

  • GNG_Virag added a tag Defect Jul 8, 2018
  • GNG_Virag posted a comment Jul 8, 2018

    Same thing with 

    /way Arathi Highlands:Eastern Kingdoms 23.32 50.30 Item

    Edited Jul 8, 2018
  • GNG_Virag posted a comment Jul 8, 2018

    And right now even WoWhead uses /way Zuldazar as main way to zuldazar. 

    http://bfa.wowhead.com/achievement=13048/life-finds-a-way-to-die

     

    I mean it is not addons problem, but should be easy enough to map Zuldazar:Zandalar to Zuldazar. 

    Anyway, right now Zuldazar:Zandalar also soesn'nt work as i said before)

  • LudovicusMaior posted a comment Aug 4, 2018

    Yeah, the zone naming code broke after some patch that blizzard made.

    I'm working on it this weekend.

  • LudovicusMaior added a tag Accepted Aug 4, 2018
  • LudovicusMaior self-assigned this issue Aug 4, 2018
  • Muchomurka2676 posted a comment Aug 20, 2018

    Its sad, but this is still not repaired :(

  • LudovicusMaior posted a comment Aug 20, 2018

    I got a fix that almost works.   Just can only work on the weekends on it.

    Wish me luck and I can finish the debugging this coming Saturday.

  • FuryusSvetlo posted a comment Aug 29, 2018

    If it helps...

     

    After I do "/way Zuldazar:Zandalar 10 10 test 1", I see the following in "/way list" output:

     

    Zuldazar:

      test 1 - 10.00, 10.00 (map: 1181)

     

    After I travel to Zuldazar and do "/way 20 20 test 2", I see the following in "/way list" output:

     

    Zuldazar:

      test 2 - 20.00, 20.00 (map: 862)

     

    This "test 2" waypoint appears correctly on the Zuldazar map. The earlier "test 1" waypoint does not.

     

    It appears to me as though using "Zuldazar:Zandalar" as a reference is directing the action onto the wrong in-game map (or some such)... at least that's my conclusion not having ever seen the program code. Seems like map 862 is the map that should be being used.

     

    Hope this helps! :)


    Edited Aug 29, 2018
  • LudovicusMaior posted a comment Aug 30, 2018

    Thanks SvetloWoW, that was just the right clue.   It means there is another Zuldazar and the wrong map has been selected.

     

     

     

     

  • Bima posted a comment Nov 30, 2018

    Just came here to observe that the problem is still ongoing (I guess as is obvious from the issue being open).  I was flumoxed as to how come the example command I was adding to a Wowhead command wasn't working, and as SvetloWoW observed it does show up in the /way list command.  It just doesn't show on the map/arrow.

     

  • karlavaegen posted a comment Jan 15, 2019

    As for me I just wanted a quick fix that works for zones...

    1. Add if (hbd.mapData[id].mapType == Enum.UIMapType.Zone) then to a new row at 1170 just below the comment "-- Record only Zone or Micro maps" in the file "TomTom.lua".

    2. In the same file add end to a new row at 1181 beteeen the other "ends".

     

    Works for me at least...


To post a comment, please login or register a new account.