Raidframes not updating with raidmember changes (during combat and after it) #865


  • Defect
  • Waiting
Open
Assigned to Ivaria
  • SarrigBlue created this issue Nov 16, 2017

    Bug related to earlier bug where Vuhdo raidframes dont update raidmembers during combat and now not even after the combat has ended the problem seems to persist. 

    This issue appears in all cross realm raidgroups (argus portals, worldbosses, fisher friends raid) same realm/server raidgroups and guild/same server/realm dungeon groups can bug out if someone dc:s but they seem to be mostly uneffected with this so far).

    Problems started to me after Wed (eu 15th Novemeber 2017) patchday. 

    Problems seems to be related to the issues that has been buggin vuhdo long time now  (since crossrealm croups I presume  - issues of not updating raidmemebers in combat) but the problems seems to have now escalated somehow and persists even after combat has ended and occasionally appears even whitout combat (with raidmemebers just joining/leaving randomly). (relates to post comments in vuh do curse download page #16062 and #16058 answer #16069 )

    Reload ui, or even relogging does not fix the issue most of the time (as it has done with the during combat updating). Only leaving raidgroup, then relogging and rejoining will - but problem can repeat itself if people join/leave raid again. I've had this happen midfight AND whitout combat as well doe to changes in raidgroup)

    Raidframes can also somehow "crash" so that thet have like 2-10 random raidmembers but not my own character visible, and sometimes they show names and classes wrong and sometimes person seems to be there twice (both dead and alive) and fewtimes reaload ui only changes couple people from the group but dosnt bring it up to speed with the real situation. DC-during midfight and relogging back on will often disable raidframes entirely as well. 

    I ran with elvui, bugsac reports no errors and all addons are updated. I do have scaling vuhdo profiles for 5man group, 10-25man raid and 25-40 raid that vuh do scales automatically. Could that have something to do with this issue? Although my alt that dosnt use that feature and has the same problem as well.

    As a mainspec healer this is really problematic bug to have. 

  • Ivaria self-assigned this issue Nov 16, 2017
  • Ivaria added the tags Defect Waiting Nov 16, 2017
  • ilintar posted a comment Nov 19, 2017

    Just wanted to chime in - have had the same problem for quite some time now (of members not refreshing). I added a macro which refreshes VuhDo (by turning the panel off and on again), but the macro doesn't work in-combat (but you can trigger it between fights to update member lists). 

    Also, sometimes members appear in an incorrect format (noticed two bugs: one is that a member will occupy only half a frame even though I don't have "show target" enabled, the other is that the frame will be too large - like it's carried over from my party config - where I use larger nameplates - to my raid config).

  • Ivaria posted a comment Nov 19, 2017

    Ok let's try a few things to try and isolate where the problem is.  While group/raid roster changes are not going to be properly reflected during combat lockdown, outside of combat everything should be working properly.

     

    Please try each of these steps independently.  Meaning do one step, test if the problem persists, then move on to the next step.  There is no need to undue any settings changed in the previous steps before continuing.

     

    • Disable all of your other add-ons except for just VuhDo and VuhDo Options.  Then go do a world boss like Apocron or Nithogg.  World bosses are great for testing in general because you can just queue for an auto-accept group and they tend to have a lot of players joining/leaving.
    • Next, try disabling the 'Activate due to group size' options of your profile.  I noticed that both of you seem to have different profiles for different group sizes and I want to see if this is part of the problem.
    • Next, under 'VuhDo Options > General > General > Hide Panels' make sure that 'Empty' and 'Empty Buttons' are both checked.
    • Next, under 'VuhDo Options > Panels > General > Ordering' make sure that 'Hide empty' is checked.
    • Also, export your profile under 'VuhDo Options > Tools > Profiles > Profiles'.  Cut and paste the string on pastebin.com or equivalent.  Then I will try importing that profile and running it myself.
    • Finally, try creating a new profile from scratch or using a default like Vuhdo'esque or Bit'o'Grid and see if you have the same problem.  You can also save a backup of your VuhDo.lua and VuhDoOptions.lua SavedVariable files under the WTF folder and then run the '/vd reset' command to completely reset all VuhDo settings.

    Edited Nov 19, 2017
  • SarrigBlue posted a comment Nov 20, 2017

    I'll try to get the test cases done mon/tue (I have bunch of alts that can do orginals bosses so they should be good way to test it).  I might have a workaround solution in mind too, but I'll test it too too to see if it actually sticks. :)

  • ilintar posted a comment Dec 12, 2017

    Narrowed it down to a (most likely) conflict with WorldQuestTracker (selectively reenabled addons, that's the one that broke it).

  • zehnkilobienen posted a comment Dec 19, 2017

    Got the same issues with changes to raid frame numbers (not actual values) taking an eternity to load,  kinda assumed my computer just hated the sheer amount of stuff happening at once - but reading Sarrig's mention of the 15thNov EU patch made me realize raid healing worked just fine for me til then. 

     

    Tbh i plain suck at this game, so the only time i heal groups is during world quests/Argus invasion points and i can't say how frames behave in current content dungeon/raid groups. This never happens in the occasional AV raids with its relatively low fluctuation of raid members, though.

     

    What happens is basically this: Whenever i enter an invasion raid the few people already present or joining before i enter combat are shown as raid frames, and as long as there isn't a rapid rise in joining players they usually (not always afaik) manage to update decently. However, a lot of the time i'm looking at three or four player frames for the majority of the invasion point while being surrounded by dozens of people - only to see raid frames updating after the boss got defeated. 

     

    Can't say how much the default chat texts and vuhdo frames interact, but the chat messages informing me of joining players occur at the same time of sudden mass updates, so i wouldn't rule out issues unrelated to this addon. As already said, though, this worked perfectly fine until said November patch. None of the other issues Sarrig mentioned (crashed frames, duplicated or hiccup'd frames with wrong info, "???" names and dc displays for online characters, etc) occured for me all that often, and when they do they usually fix themselves immediately. 

     

    Not using WorldQuestTracker, so it can hardly be the culprit in this case. Will try to do vuhdo-only invasion points once i got a bit more time on my hands, but won't promise anything. 

     

    Edit: Whoops, dug through the older comments some more and realized it's most likely caused by the game itself rather than vuhdo. Still, it's not exclusively limited to in-combat=stalled raid frame numbers. In some invasion points it actually works optimally, while in some others it inexplicably doesn't, and by inexplicably i mean in all possible combinations of invasion point types/being in combat or not/group member increase per minute/etc. The rate of it not working has just increased dramatically as of the Nov 15th patch. 


    Edited Dec 20, 2017

To post a comment, please login or register a new account.